Topic: Themes plugin not in 2015-02-20 project?  (Read 3335 times)

0 Members and 1 Guest are viewing this topic.

Themes plugin not in 2015-02-20 project?
« on: February 19, 2015, 08:42:56 PM »

Atari800xl

  • Code Baker
  • Sr. Chef
  • ****
  • Date Registered: Feb 2013
  • Posts: 754
Hi ChrisR,
Thanks for the updated project files. I'm doing my edits and mods to the new files, and noticed there's no "Tweaks\Theme.script". Is this "by design", or did you forget it? According to my notes, I need it in 8PESE, because otherwise the start button has no icon, but just a black picture instead.
Of course, I can replace my previous Tweaks.script, but I just wanted to ask ask quickly as possible.
Thanks again for all your hard work!!!
 :thumbsup:
« Last Edit: February 06, 2016, 02:27:16 AM by Lancelot »

Re: Themes script not in 2015-02-20 project?
« Reply #1 on: February 19, 2015, 10:48:51 PM »

Lancelot

  • Gena Baker
  • Grand Chef
  • *****
  • Date Registered: Sep 2010
  • Posts: 6732
Hi Atari800xl,

1) Have you made test build ?

2) Is start menu working ?

3)

:turtle:

Re: Themes script not in 2015-02-20 project?
« Reply #2 on: February 19, 2015, 11:07:53 PM »

ChrisR

  • Moderator, Win7PE SE Baker
  • Grand Chef
  • *****
  • Date Registered: Mar 2011
  • Posts: 2785
Hi Atari800xl,

I probably would have to specify :wink:
The theme plugin was moved in the Build folder. Same for the "Windows Driver Foundation".
thus, almost all mandatory plugins are at the beginning now, easier for sélections or to make a basic build  :cool:

Re: Themes script not in 2015-02-20 project?
« Reply #3 on: February 19, 2015, 11:12:38 PM »

Lancelot

  • Gena Baker
  • Grand Chef
  • *****
  • Date Registered: Sep 2010
  • Posts: 6732
Ah Chris,

Why not improve development capabilities of Atari800xl,
 see KYHI   :smile:

:turtle:

Re: Themes script not in 2015-02-20 project?
« Reply #4 on: February 19, 2015, 11:22:03 PM »

ChrisR

  • Moderator, Win7PE SE Baker
  • Grand Chef
  • *****
  • Date Registered: Mar 2011
  • Posts: 2785
yep, KYHI learns well and fast  :thumbsup:
He could testify, that it is not so hard :wink:

Atari, it is more by design with its ISO apps mounted at startup, i believe.
But it could make nice things, if he wanted  :thumbsup:

Re: Themes script not in 2015-02-20 project?
« Reply #5 on: February 19, 2015, 11:29:15 PM »

Lancelot

  • Gena Baker
  • Grand Chef
  • *****
  • Date Registered: Sep 2010
  • Posts: 6732
Well,
it is always better our regular members learn doing basics easly  :wink:
 like checking log to see where Themes is  :smile:
  following 1) 2)  above
   btw, 3) is "Take it easy" or "First check than shoot is better than first shoot than check" (Google: "Shoot first, then talk" )
:turtle:

Re: Themes script not in 2015-02-20 project?
« Reply #6 on: February 19, 2015, 11:33:06 PM »

Atari800xl

  • Code Baker
  • Sr. Chef
  • ****
  • Date Registered: Feb 2013
  • Posts: 754
Sorry, I don't understand anything about Lancelot's reaction. It must be a language thing.

ChrisR, thanks for your reply. Sorry for overlooking the script.
I have made a small "Howto" list for myself, describing all the things I'm changing with every new projects release. In this file, I made a note to myself "Don't delete the Themes script in Win8PESE, or else the start menu will go black". That's why I asked, again: Sorry to bother you.
Funny thing is: In 8.1SE, it's not a problem when the Theme script is missing. All windows are nice and boring looking, just the way I want it!  :smile:

I like to take this opportunity to thank you for the "Show Win+T"/ TextOnTop script, very nicely done, I've mentioned the Win+T issue on MDL again as well, maybe something will come of it in future...

Re: Themes script not in 2015-02-20 project?
« Reply #7 on: February 19, 2015, 11:48:47 PM »

Lancelot

  • Gena Baker
  • Grand Chef
  • *****
  • Date Registered: Sep 2010
  • Posts: 6732
Sorry, I don't understand anything about Lancelot's reaction. It must be a language thing.

no it is not, it is about your selective perspective.

   very clear to the rest, reason described at 3)


3) is "Take it easy" or "First check than shoot is better than first shoot than check" (Google: "Shoot first, then talk" )

with other words, don't be a lazy student.

:turtle:

Re: Themes script not in 2015-02-20 project?
« Reply #8 on: February 19, 2015, 11:54:07 PM »

Lancelot

  • Gena Baker
  • Grand Chef
  • *****
  • Date Registered: Sep 2010
  • Posts: 6732
See Chris,

make same observation with your kids  :smile:

Back to UniverCity, I am with lots of students and teachers,
 especially the ones (students) from technical engineering (2 years course) always do same things (same routine),

Well lots of story there  :lol: this is the most common  :wink:

Re: Themes script not in 2015-02-20 project?
« Reply #9 on: February 20, 2015, 06:51:09 AM »

Prz42

  • Code Baker
  • Chef
  • ***
  • Date Registered: Jan 2014
  • Posts: 373
I just want to say that with the new MyPlugins_Direct it make the project very easy to update.
I didn't download Chris's new update directly, but did the (Exact and Secure) and it went without
a flaw. I moved all the apps to MyPlugins_Direct and when it was done there was no double up
programs. I didn't even notice the theme's being moved to the new location, but everything at
the next build was perfect. Great improvements.  :thumbsup: I do notice that sometimes when
I use the utility PC Pack, PC Provide Files & PC Innounp it blows up the program.  I then move the
script out of the newly formed Win8.1SE\Projects\MyPlugins\AppsMy\1Prepare and it returns to normal. :confused:

Re: Themes script not in 2015-02-20 project?
« Reply #10 on: February 20, 2015, 07:56:27 AM »

Lancelot

  • Gena Baker
  • Grand Chef
  • *****
  • Date Registered: Sep 2010
  • Posts: 6732
I just want to say that with the new MyPlugins_Direct it make the project very easy to update.
I didn't download Chris's new update directly, but did the (Exact and Secure) and it went without
a flaw. I moved all the apps to MyPlugins_Direct and when it was done there was no double up
programs.
:thumbsup:

Well, MyPlugins do same thing if you had used before  :wink:
 and MyPlugins_Direct method not new, method used since first Gena-Sweets distribution (>5 years) only now it is added for MyPlugins. Anyway Idea now came to my mind to add for conventional users.

I didn't even notice the theme's being moved to the new location, but everything at
the next build was perfect.
:cool:

ps: ah Atari800xl ah  :wink:

Great improvements.  :thumbsup: I do notice that sometimes when
I use the utility PC Pack, PC Provide Files & PC Innounp it blows up the program.  I then move the
script out of the newly formed Win8.1SE\Projects\MyPlugins\AppsMy\1Prepare and it returns to normal. :confused:
I see picture,
   this never happened here (yet). (I guess host same, Win81x64)
     if you can provide a way to reproduce  :thumbsup:


but maybe:
 since Win81 host, I notice visual anomaly (very same with yours) with builder interface (on editor side which I use more),
   it disappears when you move up down with scrollbox,
    on your case, click + sign near components, shell and use scrollbox that will appear right to move up down. (right of treeview)

I didn't have your picture, maybe only because I have all projects on tree view which already goes very down (unlike your case)
 (I tested with only Win81SE but it did not happen for now )

If that is the case, what you do for fix is not about moving plugin to another location, it is about restarting/refreshing builder  :smile:
 
If that is the case, yet another winbuilder bug  :wink:

I believe that is the case  :lol:




Shortly:
When this happens again, try
 click + sign near components, shell and use scrollbox that will appear right of treebox to move up down
 (on your case down and up).

Let us know what happens  :thumbsup:

Re: Themes script not in 2015-02-20 project?
« Reply #11 on: February 20, 2015, 08:40:10 AM »

KYHI

  • Code Baker
  • Sr. Chef
  • ****
  • Location: Kentucky
  • Date Registered: Jan 2015
  • Posts: 909
actually when I use the create plugins - i get myscripts - myapps - myplugins - depending on which one you use.. I think there are four different folders being created via create plugins..

I use just one..

%Tar%=%ProjectDir%\AppsMy
%TarMy%=%ProjectTemp%\MyPlugins

But I also do not like all the sub sub-folders (JMO)
« Last Edit: February 20, 2015, 08:42:42 AM by KYHI »

Re: Themes script not in 2015-02-20 project?
« Reply #12 on: February 20, 2015, 08:49:10 AM »

Lancelot

  • Gena Baker
  • Grand Chef
  • *****
  • Date Registered: Sep 2010
  • Posts: 6732
Hi KYHI,

All Plugin Creators create plugins under only 1 folder,
\MyPlugins\AppsMy\1Prepare\

if created plugin under another folder (you count 4 !!)  let me know location ?


+
sub-sub folder have a logical design  :wink:
 it is not easy to decide how much is enough how much is much......
   one say too complicated, other say too many sub sub, we try to find a mid way....
     Well we are open to suggestions  :great:

:turtle:

Re: Themes script not in 2015-02-20 project?
« Reply #13 on: February 20, 2015, 08:54:28 AM »

KYHI

  • Code Baker
  • Sr. Chef
  • ****
  • Location: Kentucky
  • Date Registered: Jan 2015
  • Posts: 909
yep, KYHI learns well and fast  :thumbsup:
He could testify, that it is not so hard :wink:

I have copy and paste down pretty good...

I know what I want it to do - just have to read other scripts to find the code to do it..

I can follow code - just don't write..

But did find the macro help.. By mistake really because I pulled a macro error..

« Last Edit: February 20, 2015, 08:56:35 AM by KYHI »

Re: Themes script not in 2015-02-20 project?
« Reply #14 on: February 20, 2015, 10:01:46 AM »

Lancelot

  • Gena Baker
  • Grand Chef
  • *****
  • Date Registered: Sep 2010
  • Posts: 6732
I have copy and paste down pretty good...

I know what I want it to do - just have to read other scripts to find the code to do it..

I can follow code - just don't write..
Well, imagine many can't do that,
 Even simplest things (like first testing than asking ;))

Copy Paste best way  :thumbsup:
 It also protects you from winbuilder bugs  :thumbsup:
  (+Utils\RegCPE + Utils\PCxx + ...)

But did find the macro help.. By mistake really because I pulled a macro error..
Macro Library plugin have links on it,
 and there is even a dedicated section http://theoven.org/index.php?board=14.0

*
We are around to feedback when you need  :great:

:turtle:

Re: Themes script not in 2015-02-20 project?
« Reply #15 on: February 20, 2015, 10:05:43 AM »

KYHI

  • Code Baker
  • Sr. Chef
  • ****
  • Location: Kentucky
  • Date Registered: Jan 2015
  • Posts: 909
help is no good when you do not know what a macro is.. LOL

Now I know.. I looked at the macro link.. because of the error..

Sometimes you got to break something - so you can figure out how to fix it..
« Last Edit: February 20, 2015, 10:07:56 AM by KYHI »

Re: Themes script not in 2015-02-20 project?
« Reply #16 on: February 20, 2015, 10:08:57 AM »

Lancelot

  • Gena Baker
  • Grand Chef
  • *****
  • Date Registered: Sep 2010
  • Posts: 6732

 

Powered by EzPortal