Topic: WinBuilder077RC2.exe /run="xxx" Win7 x64 crashes  (Read 1934 times)

0 Members and 1 Guest are viewing this topic.

WinBuilder077RC2.exe /run="xxx" Win7 x64 crashes
« on: March 18, 2015, 10:28:04 AM »

apinux

  • Jr. Chef
  • **
  • Date Registered: Nov 2011
  • Posts: 51
I am running Windows 7 x64 and WinBuilder077RC2

I have followed the instructions to run WinBuilder from the command line from this page

https://code.google.com/p/winbuilder/wiki/wbcmdline

If I run the following from a command line (CMD.EXE) WinBuilder pops up a crash box.

Code: [Select]
WinBuilder077RC2.exe /run="C:\WB\Projects\Gena" /title="Gena" /x=10 /y=50
               /target="C:\WB\Target\Gena"
               /ISO="C:\WB\ISO\Gena_WIM.iso"
               /log="BuildLog.html" /source="C:\WB\Source\WINXP_EN_SP3"

Code: [Select]
Access violation at address 004AE544 in module
'WinBuilder077RC2.exe'. Read of address 000002DC

When I press return the build continues and finishes successfully.

I thought it might be one of the command line options causing the crash, so I tried it wth just the /run option

WinBuilder077RC2.exe /run=""

But this still causes the same crash.

Code: [Select]
Access violation at address 004AE544 in module
'WinBuilder077RC2.exe'. Read of address 000002DC

Is this related to Windows 7 64 bit, or is it a known problem?

Thanks!

Re: WinBuilder077RC2.exe /run="xxx" Win7 x64 crashes
« Reply #1 on: March 18, 2015, 11:58:16 AM »

Lancelot

  • Moderator, Gena Baker
  • Grand Chef
  • *****
  • Date Registered: Sep 2010
  • Posts: 7052
well this bug was unknown to me  :lol:
 or I totally forgot since I do not use that thing (on purpose, I never like that thing as default....),
  same here with Win81x64..

I can't remember all bugs all the time, but I can assure command line options is not the problem,
 "Access violation at address" is very common with winbuilder, due to bad design and bad programming,
   that is the reason we do not use all commands on this wiki, knowing lots of them do not work as written,
    made our own set of syntax using.

it seems v80rv3 works fine with this command, but with Gena it would be slow...

My test command:
W.......exe /run="D:\Oven\Projects\Gena"

so I advice to have an autoit to click this "Ok"

There already exist
D:\Oven\Projects\Tools\Gena\x86\AU3381.exe

all you need is to write an au3 to start first before executing wb exe,
  wait this command for some seconds,
    and click ok (active and hit enter) if exists (else after some seconds close)
Quote
>>>> Window Text <<<<

Access violation at address

 :wink:

well share .au3 around if you do that  :thumbsup:
 someone else might need this workaround  :cool:

+
cd /d "%~dp0"
would useful at the top of .cmd files ;)

+
I also advice not to save log as default, there is another log bug (by bad design) which exists on all winbuilder versions,
 which can cause (as far as I remember) hang forever or something like that....
  also,
  no need log as default, projects try to save log when there is problem (mostly success) so end user can easly feedback.

+
let all have end work when you achive, with another topic  :great:

:turtle:
« Last Edit: November 25, 2015, 12:19:23 AM by Lancelot »

Re: WinBuilder077RC2.exe /run="xxx" Win7 x64 crashes
« Reply #2 on: March 22, 2015, 04:36:57 AM »

apinux

  • Jr. Chef
  • **
  • Date Registered: Nov 2011
  • Posts: 51
Problem solved by directly patching WinBuilder077RC2.exe, patch sent to Lancelot

Re: WinBuilder077RC2.exe /run="xxx" Win7 x64 crashes
« Reply #3 on: March 22, 2015, 08:00:33 AM »

Lancelot

  • Moderator, Gena Baker
  • Grand Chef
  • *****
  • Date Registered: Sep 2010
  • Posts: 7052
Thanks apinux  :smile: :smile: :smile:

 

Powered by EzPortal