Topic: .NET Framework initialization error  (Read 5315 times)

0 Members and 1 Guest are viewing this topic.

.NET Framework initialization error
« on: March 30, 2015, 03:59:59 AM »

shaikhrais

  • Apprentice
  • *
  • Date Registered: Mar 2015
  • Posts: 1
I am using

ISO =Windows 8.1 x86 - professional
I enabled NetFx3 feature with success in my extracted wim folders

But I got Following error when i start any version (2.0---4.5) of .NET Framework

.net framework initialization error
versions of the .NET Framework:

v2.0.50727 / v4.0 /v.45
Contact your application publisher for instructions about obtaining the appropriate version of the .NET Framework

I try any option but still result is same


Re: .NET Framework initialization error
« Reply #1 on: March 30, 2015, 06:38:04 AM »

Lancelot

  • Gena Baker
  • Grand Chef
  • *****
  • Date Registered: Sep 2010
  • Posts: 6973
Well I can only confirm your report  :thumbsup:

It seems plugin broken at some point, and since no one around use .net application it missed from eyes...

Thanks for reporting, Chris would probably take a look at when he finds time.

:turtle:

Re: .NET Framework initialization error
« Reply #2 on: March 30, 2015, 11:59:12 AM »

ChrisR

  • Win7PE SE Baker
  • Grand Chef
  • *****
  • Date Registered: Mar 2011
  • Posts: 2809
I do not use .Net normally, a moment that I have not tried.
I just tested with ~same config
Windows 8.1 update 3 x86 pro
NetFx3enabled with success in my extracted wim folders
.Net plugin with Run From CD and DotNet 2.0/3.0/3.5/4.5
and for testing, I added Yomi\AppY\Tests_.Net plugins + Paint.net 3.36 portable + EasyBCD
The apps have worked here  :confused:

ila_rendered

Can you enable "Create support Log" in main configuration and share it. Do you have copy errors in log ?
What .net apps do you use and do you have some portable .Net apps (or plugin) that I can test ?

Re: .NET Framework initialization error
« Reply #3 on: March 31, 2015, 01:06:25 PM »

Lancelot

  • Gena Baker
  • Grand Chef
  • *****
  • Date Registered: Sep 2010
  • Posts: 6973
Hi Chris,

retesting quickly (Enable Feature NetFx3 already made ;)),
 I guess this may help ?
Code: [Select]
[Warning]  (Macro_Library.script) DirCopy unsuccessful due to no matching directory found D:\SourceCD\Win81_x64\sources\install_wim\N\Windows\Microsoft.NET\assembly\GAC_MSIL\System.Data.resources
 [Warning]  (DotNet.script) RegDelete - Failed to delete registry key in: [HKLM\"""""Tmp_Software\Microsoft\Windows NT\CurrentVersion\KnownManagedDebuggingDlls"""],X:\Windows\Microsoft.NET\Framework64\v4.0.30319\mscordacwks.dll
 [Warning]  (DotNet.script) RegDelete - Failed to delete registry key in: [HKLM\"""""Tmp_Software\Microsoft\Windows NT\CurrentVersion\MiniDumpAuxiliaryDlls"""],X:\Windows\Microsoft.NET\Framework64\v2.0.50727\mscorwks.dll
 [Warning]  (DotNet.script) RegDelete - Failed to delete registry key in: [HKLM\"""""Tmp_Software\Microsoft\Windows NT\CurrentVersion\MiniDumpAuxiliaryDlls"""],X:\Windows\Microsoft.NET\Framework64\v4.0.30319\clr.dll

source is
9600.17050.WINBLUE_REFRESH.140317-1640_X64FRE_ENTERPRISE_EVAL_EN-US-IR3_CENA_X64FREE_EN-US_DV9

I confirm there is no directory
D:\SourceCD\Win81_x64\sources\install_wim\N\Windows\Microsoft.NET\assembly\GAC_MSIL\System.Data.resources

later I added "MS Visual C++ Runtime" which didn't help,

all AppY\Tests_.Net plugins don't work ..

"The application could not be started. You must enable the .NET Framework from the Windows Features dialog box ....."

:turtle:

Re: .NET Framework initialization error
« Reply #4 on: April 01, 2015, 10:50:15 AM »

ChrisR

  • Win7PE SE Baker
  • Grand Chef
  • *****
  • Date Registered: Mar 2011
  • Posts: 2809
Hi Lancelot,

I tested the 64 bit build, now.
Same warning here for the registy but not for the copy which ends successfully.
I corrected the typo, double quotes, for the 3 registry lines on x64 build. I also removed some useless quotes.
However, the concern "The application could not be started..." seems more related to the copy error of assembly\GAC_MSIL\System.Data.resources
I do not reproduce this Call,DirCopy error (no idea what's wrong  :confused:) and with or without the 3 registry lines, the tested apps run property here  :thumbsup:
I do not have 64 bit .Net apps on hand to test further.

* DotNet_v8.7z (527.38 kB - downloaded 69 times.)


Edit: I tested with french Win8.1 Pro x64 update3
Unfortunately, my external backup drive is dead last week (perhaps too many test done with it)  :sad: 
I lost many things, more or less important (for PE, the old SE packages and many Windows ISO).
Not a problem to re-download 9600.17050.WINBLUE_REFRESH.140317-1640_X64FRE_ENTERPRISE_EVAL_EN-US-IR3_CENA_X64FREE_EN-US_DV9
More difficult for Win7 ISO, with ISO removed from DigitalRiver servers now. However, I kept my French version.

My next external drive is not going to be very large, if I use the donations received.
At the same time, I do not do SE for that and I was able to offer a good restaurant to my wife, to thank her for her understanding, for the time spent on my PC :lol:
Thank you to the generous guys who gave :thumbsup:  the cinema is scheduled for the next gifts  :cool:
« Last Edit: April 01, 2015, 01:01:59 PM by ChrisR »

Re: .NET Framework initialization error
« Reply #5 on: April 02, 2015, 11:57:41 PM »

Lancelot

  • Gena Baker
  • Grand Chef
  • *****
  • Date Registered: Sep 2010
  • Posts: 6973
Hi Chris,

Sorry for late reply, life very busy....

I lived that hd failure before, besides other things it is very bad feeling  :sad:

In my case, after 1-2 years,
 I rescued my old failed hd,
   I bought same and replaced "controller card" on it, than it worked and I get all things out...
     Well I was lucky since failure is about "controller card" and I found exact same hd (second hand) at an internet cafe.....


+
It is Good donations used for good purpose  :smile:
 My advice, First wife than hd  :wink:

+
.net didn't work on Win81SE both x86 and x64,
I don't have System.Data.resources folder on any of my sources,

9600.17050.WINBLUE_REFRESH.140317-1640_X64FRE_ENTERPRISE_EVAL_EN-US-IR3_CENA_X64FREE_EN-US_DV9.iso
9600.17050.WINBLUE_REFRESH.140317-1640_X86FRE_ENTERPRISE_EVAL_EN-US-IR3_CENA_X86FREE_EN-US_DV9.iso

Well I tested with Win7PESE x86, and it worked fine without System.Data.resources folder
X17-59463.iso

maybe shaikhrais have same case...

At least we figure out the trouble  :thumbsup:
(since I don't use .net on SE, not important to me ;) )

See You
:turtle:
« Last Edit: April 02, 2015, 11:59:15 PM by Lancelot »

Re: .NET Framework initialization error
« Reply #6 on: April 03, 2015, 01:48:28 AM »

KYHI

  • Code Baker
  • Sr. Chef
  • ****
  • Location: Kentucky
  • Date Registered: Jan 2015
  • Posts: 909
these are host 8.1 > Windows\Microsoft.NET\assembly\GAC_MSIL\System.Data.*  folders - each one has a subfolder and a DLL file of same name as folder
ila_rendered

the 3 RegDelete files are present in the listed location on host C

only find manifests

"C:\Windows\WinSxS\Manifests\msil_system.data.resources_b77a5c561934e089_4.0.9600.16384_en-us_01f3b38fbdf09ed8.manifest"
"C:\Windows\WinSxS\Manifests\msil_system.data.resources_b77a5c561934e089_6.3.9600.16384_en-us_57565ad1dbeb5b9f.manifest"
"C:\Windows\WinSxS\Manifests\msil_system.data.resources_b77a5c561934e089_6.3.9600.17226_en-us_57502d8fdbf0f3ad.manifest"
"C:\Windows\WinSxS\Manifests\msil_system.data.resources_b77a5c561934e089_6.3.9600.20708_en-us_40805635f59a5864.manifest"
« Last Edit: April 03, 2015, 03:25:07 AM by KYHI »

Re: .NET Framework initialization error
« Reply #7 on: April 03, 2015, 12:19:44 PM »

ChrisR

  • Win7PE SE Baker
  • Grand Chef
  • *****
  • Date Registered: Mar 2011
  • Posts: 2809
I downloaded 9600.17050.WINBLUE_REFRESH.140317-1640_X64FRE_ENTERPRISE_EVAL_EN-US-IR3_CENA_X64FREE_EN-US_DV9
Indeed assembly\GAC_MSIL\System.Data.resources is not there in ENU ISO  :thumbsup:

In french ISO I have the dll System.Data.Resources.dll in assembly\GAC_MSIL\System.Data.resources\2.0.0.0_fr_b77a5c561934e089 folder.
It must be present only for localized ISO, I guess.
To avoid the warning in log, I will add If,ExisteDir,...

About WinSxS, I do not think that manifests files are required. Unless really required, it is best to avoid WinSXS.

maybe shaikhrais have same case...
bump  :huh:

I do not use .Net also on SE, too big, heavy,... even if copied on USB, not for me.
But the plugin is here, for those who use or develop Net Apps. Thanks to 2aCD  :smile:
« Last Edit: April 03, 2015, 12:22:29 PM by ChrisR »

 

Powered by EzPortal