Topic: NVME Driver Setup  (Read 923 times)

0 Members and 1 Guest are viewing this topic.

NVME Driver Setup
« on: October 17, 2016, 10:37:09 AM »

All_The_Drivers

  • Apprentice
  • *
  • Date Registered: Oct 2016
  • Posts: 4
Now that NVME SSD are the standard on new hardware, does anyone have solid solutions for accessing these devices in Win7PE? (ie working driver packs).

I am deploying custom images through Win7PE/WinBuilder. The Samsung drivers BSOD/require a reboot. Intel / Windows do not have working stand alone packs that I've been able to find. Search here turned up a single thread: Driver Integration on Z170 System.  Winbuilder makes the boot.wim on the fly, so I'm unsure how to add the MS KB packs to system.


Re: NVME Driver Setup
« Reply #1 on: October 18, 2016, 08:31:23 AM »

Lancelot

  • Gena Baker
  • Grand Chef
  • *****
  • Date Registered: Sep 2010
  • Posts: 7012
See & Read
http://theoven.org/index.php?topic=1910

Now that NVME SSD are the standard on new hardware,
not on Win7,
You can test with Win8PESE, Win8.SE Win10PESE to test if standard and available and feedback around.

Also If you have a working XP/2k3 driver, let us know.  :wink:

Re: NVME Driver Setup
« Reply #2 on: October 19, 2016, 09:14:42 AM »

Holger

  • Jr. Chef
  • **
  • Location: Munich
  • Date Registered: Oct 2011
  • Posts: 29
Try with DISM:
https://msdn.microsoft.com/en-us/library/ff794819.aspx

[EDIT]:
I did some tests, to apply the MS msu package with DISM you need to add some dirs/files from boot-wim-source to the boot-target (example for x86-source):

"\Windows\System32\catroot\{F750E6C3-38EE-11D1-85E5-00C04FC295EE}" -> just the directory seems to be needed
"\Windows\winsxs\Manifests\x86_microsoft-windows-classpnp_31bf3856ad364e35_6.1.7601.17514_none_178a98870a53ee4d.manifest"
"\Windows\winsxs\Manifests\x86_microsoft-windows-imagebasedsetup-media_31bf3856ad364e35_6.1.7601.17514_none_721540bbe51e7831.manifest"
"\Windows\winsxs\Manifests\x86_microsoft-windows-storport_31bf3856ad364e35_6.1.7601.17514_none_2983b8948e70fede.manifest"

"\Windows\winsxs\x86_microsoft-windows-classpnp_31bf3856ad364e35_6.1.7601.17514_none_178a98870a53ee4d\*.*"
"\Windows\winsxs\x86_microsoft-windows-imagebasedsetup-media_31bf3856ad364e35_6.1.7601.17514_none_721540bbe51e7831\*.*"
"\Windows\winsxs\x86_microsoft-windows-storport_31bf3856ad364e35_6.1.7601.17514_none_2983b8948e70fede\*.*"
« Last Edit: October 23, 2016, 11:54:48 PM by Holger »

Re: NVME Driver Setup
« Reply #3 on: October 24, 2016, 04:55:26 AM »

All_The_Drivers

  • Apprentice
  • *
  • Date Registered: Oct 2016
  • Posts: 4
Summary (correct me if I'm wrong):
PE 4.x, 5.x and 10.x all see NVME fine. 3.1 won't unless you pre-load separate drivers.

HP's white paper & link to driver listings for NVME & WinPE:
newbielink:https://ftp.hp.com/pub/caps-softpaq/cmit/whitepapers/Windows_7_OS_Install_NVME.pdf [nonactive]
newbielink:http://ftp.hp.com/pub/caps-softpaq/cmit/HP_WinPE_DriverPack.html [nonactive]

I'm looking for a single place to reference all working methods/drivers location for all NVME in 3.x PE environment. There is information out there, but it's scattered & not always easy to find.


Personally, I'm having trouble getting the drivers and MS packs injected and working. I'm currently using WinBuilder to build an ISO that boots into PE in order to launch a script that prep's the hdd then applies the image via DISM.  It's clunky and has evolved over the last decade from the previous two guys.

In the WinBuilder enviro, the MS hotfixes won't apply. The Samsung and Intel drivers are asking to reboot after initializing. The results being Disk 0 mounts temporarily then ceases to be available or mountable.

Re: NVME Driver Setup
« Reply #4 on: October 24, 2016, 08:55:40 AM »

Holger

  • Jr. Chef
  • **
  • Location: Munich
  • Date Registered: Oct 2011
  • Posts: 29
I only downloaded the KB2990941 and made a small script to integrate the MSU file with DISM and could access normally my 950 pro NVME drive under Win7PE_SE.
From that drive I also started MSPaint to save the screenshot.

Re: NVME Driver Setup
« Reply #5 on: October 25, 2016, 08:41:39 PM »

Holger

  • Jr. Chef
  • **
  • Location: Munich
  • Date Registered: Oct 2011
  • Posts: 29
I made a small and simple script, not really optimized but I did 2 tests yesterday with english and german source and it worked so far.
Primary you only need to request the KB2990941 hotfix download at Microsoft, the 2 other KB's (which are documented in the PDF from HP) are not really needed for accessing the NVMe drive.

Greets
Holger

Re: NVME Driver Setup
« Reply #6 on: October 31, 2016, 06:02:12 AM »

All_The_Drivers

  • Apprentice
  • *
  • Date Registered: Oct 2016
  • Posts: 4
Thank for the response on this. The PE version in WinBuilder isn't taking the KB. Currently working on moving off of WinBuilder to the default PE environment. The AIK version is working fine for me with the method you suggested.

 

Powered by EzPortal