Topic: How to disable default HotKey in Pecmd?  (Read 2238 times)

0 Members and 1 Guest are viewing this topic.

How to disable default HotKey in Pecmd?
« on: July 03, 2014, 01:40:21 AM »

MaS

  • Apprentice
  • *
  • Date Registered: Jun 2014
  • Posts: 5
The famous Chinese Pecmd has default hotkey build in self: Ctrl+Alt+A which change resolution to 800x600.

Does anybody know how to disable/release/overcome this feature?

Re: How to disable default HotKey in Pecmd?
« Reply #1 on: July 03, 2014, 03:10:59 PM »

SIW2

  • Code Baker
  • Chef
  • ***
  • Date Registered: Jul 2012
  • Posts: 167
You can preset any res you like by adding a line at the beginning of pecmd.ini.

e.g:


     DISP W1024 H768 B32 F60
     LOGO %windir%\web\wallpaper\windows\img0.jpg

If you mean in the pecmd tray menu, you may be able to override it. I haven't tested it though.

E'G if you want ctrl+alt+a to launch notepd, the pecmd.ini entry would be:

HOTK Ctrl + Alt + A,EXEC NOTEPAD.EXE

pecmd 88.01 versions attached

* pecmd88.01-en-menu.zip (839.42 kB - downloaded 118 times.)
« Last Edit: July 03, 2014, 04:01:07 PM by SIW2 »

Re: How to disable default HotKey in Pecmd?
« Reply #2 on: July 06, 2014, 11:48:21 PM »

MaS

  • Apprentice
  • *
  • Date Registered: Jun 2014
  • Posts: 5
I don't want to change/override this hotkey by the line at pecmd.ini.
I want to eliminate Ctrl+Alt+A hotkey.
Why?
Because in several European languages we have additional letters (i.e. letters with "little tail") and to write them we use two keys: Alt+"standard letter".
When I press Alt+A I want to write my letter, but default hotkey in Pecmd.exe is changing resolution to 800x600.

I think that very simple way to eliminate this hotkey is small change in source code of pecmd.exe (to cut/comment line with this hotkey) and then recompilation.
But I don't have source code of pecmd.exe and I don't know if it is available.

Has anybody source code of pecmd.exe?

or maybe there is another way to eliminate this hotkey?

Re: How to disable default HotKey in Pecmd?
« Reply #3 on: July 08, 2014, 12:40:57 PM »

SIW2

  • Code Baker
  • Chef
  • ***
  • Date Registered: Jul 2012
  • Posts: 167
Easiest way is to add this in pecmd.ini

REGI $HKLM\SOFTWARE\PELOGON\hotkey1!

e.g.

     TEAM SHEL %SystemRoot%\explorer.exe|WAIT 1000|LOGO
     WAIT 100
     TEAM FILE %public%\desktop\desktop.ini|FILE X:\Users\Default\Desktop\desktop.ini
     REGI $HKLM\SOFTWARE\PELOGON\hotkey1!
« Last Edit: July 08, 2014, 12:41:37 PM by SIW2 »

Re: How to disable default HotKey in Pecmd?
« Reply #4 on: July 09, 2014, 01:04:22 AM »

MaS

  • Apprentice
  • *
  • Date Registered: Jun 2014
  • Posts: 5
This is what I was looking for !!!
Thank you

Re: How to disable default HotKey in Pecmd?
« Reply #5 on: July 09, 2014, 06:03:04 PM »

SIW2

  • Code Baker
  • Chef
  • ***
  • Date Registered: Jul 2012
  • Posts: 167
You're welcome.

Re: How to disable default HotKey in Pecmd?
« Reply #6 on: November 24, 2016, 10:24:40 AM »

shazza

  • Apprentice
  • *
  • Date Registered: Nov 2016
  • Posts: 7
I have the same problem but :

REGI $HKLM\SOFTWARE\PELOGON\HOTKEY!

not working for me.Help me please...

http://picsee.net/upload/2016-11-24/35eae7b65b0b.png
http://picsee.net/upload/2016-11-24/f82fc9a0f8d3.png


 

Powered by EzPortal