Topic: Explore network path under Win7PESE  (Read 1073 times)

0 Members and 1 Guest are viewing this topic.

Explore network path under Win7PESE
« on: January 09, 2017, 12:05:15 PM »

Rui Paz

  • Code Baker
  • Jr. Chef
  • **
  • Date Registered: Mar 2011
  • Posts: 47
Hi,

I have been trying to find if it's possible to access network paths on Win7PE without the need of mapping a drive to the network share first.

I'm posting my findings so others can contribute and eventually we could find the solution for the problem I have found.

On my test if I try to directly access a network path from the Run box the result is this:
ila_rendered

What I found is that if the file networkexplorer.dll doesn't exist on the system32 folder, instead of the error above it works as in normal windows and we get a prompt for the user and password to access the protected network share but after authenticated successfully we get the error Windows cannot access \\192...
ila_rendered

Now the curious part (for me) is, if instead of using the Run box I open the Computer icon and use the address bar to access the network path like show in the next image it works properly showing the credentials prompt and browsing the shared folder without any problem!
ila_rendered

Edit: After a successful login the run box can then be used to access the network share including other shares on the same host.
If I try to access a different share on another machine from the run box it will fail again with the same error and the workaround with the Computer window must be used again for the new network path.

Information about the options used on the project:
- 1 - Copy Files: Standard
- 5 - µExplorer Shell with networkexplorer.dll and NetworkExplorer.dll.mui added to system32 and System32\en-US\ respectively

The result of my tests don't change if I use the 1 - Explorer Shell script instead of µExplorer Shell.


Anyone have ideas to fix this and makes the run box work as it should?
« Last Edit: January 13, 2017, 01:55:26 PM by Lancelot »

Re: Explore network path under Win7PESE
« Reply #1 on: January 13, 2017, 06:42:21 AM »

2aCD

  • Code Baker
  • Jr. Chef
  • **
  • Location: Dresden, Germany
  • Date Registered: May 2013
  • Posts: 80
Yes, this is a known issue.
I have invested a lot of time to find a solution for this problem.
If you use the run dialog to connect with a UNC-share no credential window is called.
Only with explorer address bar the credential window is showing up.
Unfortunately that's how it is.
Best regards
2aCD
« Last Edit: January 13, 2017, 01:55:42 PM by Lancelot »

Re: Explore network path under Win7PESE
« Reply #2 on: January 16, 2017, 11:50:45 AM »

Rui Paz

  • Code Baker
  • Jr. Chef
  • **
  • Date Registered: Mar 2011
  • Posts: 47
Hi 2aCD,

Thanks for the reply. I suppose that to fix this we have to "inject" some change on Explorer or loaded dll but this is out of my league!

I also found that we don't need to use Explorer to get the credential window it also work inside the Run Box if we click browse and use the address bar on top of the browse window.

Did more testing and if we change the user used on WinPE from System to Administrator using the option available on the xDisplay script then the run box works fine. It seems the problem is somehow related with having SYSTEM permissions.
« Last Edit: January 16, 2017, 11:51:54 AM by Rui Paz »

 

Powered by EzPortal