Topic: Win10SE_ PE Errors when compiling project  (Read 484 times)

0 Members and 1 Guest are viewing this topic.

Win10SE_ PE Errors when compiling project
« on: September 20, 2017, 07:25:16 AM »

AnarchistedEd

  • Apprentice
  • *
  • Date Registered: Sep 2017
  • Posts: 4
Hola

I am using WinPESE v72 and receive the following error message when i go and hiot the Big Blue Play button:

 [Failed]  (2-Config.script) RegHiveLoad - Failed to load registry hive: [Software] From file: [%BaseDir%\Target\Win10PESE\Windows\System32\config\Software]: Unknown error

anyone encounter this before? Anyone know how fix\workaround this error? Entire log attatched.

Thanks for your help!!!!

Re: Win10SE_ PE Errors when compiling project
« Reply #1 on: September 20, 2017, 08:52:02 AM »

AnarchistedEd

  • Apprentice
  • *
  • Date Registered: Sep 2017
  • Posts: 4
Soooooooo......i downloaded one of the ISO that was recommenced for this version of WinBuilder, Windows 10 x64 1607, and used those files as the source, and am still getting the same error when it runs through the Build | Shell and config part of the process:
 [Failed]  (2-Config.script) RegHiveLoad - Failed to load registry hive: [Software] From file: [%BaseDir%\Target\Win10PESE\Windows\System32\config\Software]: Unknown error

so now i have to ask a stupid question. i am using a Windows 10 enterprise ver 1607 machine to try and create this WinPE disk, does that matter?

complete log attatched:

Thanks for your help!!!

Re: Win10SE_ PE Errors when compiling project
« Reply #2 on: September 20, 2017, 10:26:52 AM »

bob.omb

  • Chef
  • ***
  • Location: USA
  • Date Registered: Jul 2017
  • Posts: 103
Something probably already has the hive loaded have you made any changes to any scripts? I have only seen that error when "Additional Registry Items" script was enabled and RegHiveLoad%XXX% was used inside that script.  It would error out because the script already loads the registry so you have to exclude the RegHiveLoad and RegHiveUnload.  Which is what leads me to believe that the registry is already loaded somehow.  Or there is a problem with your source.  Are you using extracted media or mounting an ISO for source?
« Last Edit: September 20, 2017, 10:30:31 AM by bob.omb »

Re: Win10SE_ PE Errors when compiling project
« Reply #3 on: September 20, 2017, 10:45:25 AM »

AnarchistedEd

  • Apprentice
  • *
  • Date Registered: Sep 2017
  • Posts: 4
Hola

I am using extracted files from an ISO that I downloaded via a link off of the WinPe Se front end in the application. I do not have anything tied interest the registry.  As far as the script goes. How do I turn that off or is that just not a good idea?

Re: Win10SE_ PE Errors when compiling project
« Reply #4 on: September 20, 2017, 02:06:11 PM »

bob.omb

  • Chef
  • ***
  • Location: USA
  • Date Registered: Jul 2017
  • Posts: 103
Are you running BuilderSE.exe as an administrator?

Re: Win10SE_ PE Errors when compiling project
« Reply #5 on: September 20, 2017, 08:29:53 PM »

t6nna

  • Jr. Chef
  • **
  • Date Registered: Apr 2016
  • Posts: 25
Clear the checkbox Stop Build on Error under program Tools->Options and try again

Re: Win10SE_ PE Errors when compiling project
« Reply #6 on: September 21, 2017, 12:30:03 AM »

Lancelot

  • Gena Baker
  • Grand Chef
  • *****
  • Date Registered: Sep 2010
  • Posts: 7239
Clear the checkbox Stop Build on Error under program Tools->Options and try again
NEVER do that. not a good idea.

Re: Win10SE_ PE Errors when compiling project
« Reply #7 on: September 21, 2017, 12:30:49 AM »

Lancelot

  • Gena Baker
  • Grand Chef
  • *****
  • Date Registered: Sep 2010
  • Posts: 7239
Hi AnarchistedEd,

at FAQ topic
http://theoven.org/index.php?topic=834.0
follow steps after this title:

My Build Fails (or Halt or BSOD or any other trouble) - What to do  ?
« Last Edit: September 21, 2017, 12:51:56 AM by Lancelot »

Re: Win10SE_ PE Errors when compiling project
« Reply #8 on: September 21, 2017, 03:28:02 PM »

bob.omb

  • Chef
  • ***
  • Location: USA
  • Date Registered: Jul 2017
  • Posts: 103
I just looked through the link Lancelot posted and there's too much there to put in here.  There are a lot of different things you could try.  The section is labeled with a blue title near the top of the referenced post.
« Last Edit: September 21, 2017, 03:35:14 PM by bob.omb »

Re: Win10SE_ PE Errors when compiling project
« Reply #9 on: September 22, 2017, 09:04:04 AM »

AnarchistedEd

  • Apprentice
  • *
  • Date Registered: Sep 2017
  • Posts: 4
All

Thank you all for your efforts. I cheated a bit and reimaged the macine with the ISO I downloaded. After doing so it has worked flawlessly. I probably should have done that to begin with........ live and learn I guess

Re: Win10SE_ PE Errors when compiling project
« Reply #10 on: September 23, 2017, 08:39:16 AM »

bob.omb

  • Chef
  • ***
  • Location: USA
  • Date Registered: Jul 2017
  • Posts: 103
Its not cheating, lol.  If some pre-existing settings in your workstation were stopping the builder from functioning correctly its unlikely anyone here would've been able to help.  Everything is a learning experience. Glad you got it working!

Re: Win10SE_ PE Errors when compiling project
« Reply #11 on: September 24, 2017, 03:51:14 AM »

Lancelot

  • Gena Baker
  • Grand Chef
  • *****
  • Date Registered: Sep 2010
  • Posts: 7239
I never need to reimage my windows to build any projects with any source.

We have prechecks on projects to prevent end user from bad host settings,
 but requires end user report personal setting that cause malfunction.

Well, reinstall or reimage windows simply clears all end user settings and clean all installed bad applications.  :wink:

Since this fix unknown things on your host, This will also get your other applications work better.

:turtle:

 

Powered by EzPortal