Topic: PECMD: pecmd.exe - unknown hard error  (Read 300 times)

0 Members and 1 Guest are viewing this topic.

PECMD: pecmd.exe - unknown hard error
« on: October 01, 2017, 12:52:56 PM »

dazza

  • Apprentice
  • *
  • Date Registered: Jan 2017
  • Posts: 9
Hi all

Just tried building latest Win10PESE and it all appears to build okay, but when I boot it starts booting fine then I get black screen and window titled PECMD:pecmd.exe- System Error and says Unknown Hard Error

Tried building again multiple times, checked source, searched forum, looked at FAQ's etc, but can't find any mention

Before I updated plugin to latest version it all worked fine, only changes are new plugins from 25/08/17 release and changing source to Win 10 1703 Creator Update (build 15063) as it said supported - got ISO from approved link e.g. www.heidoc.net......

Before I start again and enable plugins one at a time, does anyone have a clue as to what might be the cause please?

Many thanks

Re: PECMD: pecmd.exe - unknown hard error
« Reply #1 on: October 01, 2017, 01:21:26 PM »

bob.omb

  • Chef
  • ***
  • Location: USA
  • Date Registered: Jul 2017
  • Posts: 103
Did you modify any of your plugins?  I noticed little changes here and there I made directly to some of the main plugins that I was using was causing a problem.  I re-downloaded Win10PESE.zip and created another build folder.  I then did a BL exact and secure.  Then I had a fresh untouched build.  I migrated my scripts over one at a time and was able to find which base script I modified that was causing my issue.  It takes some time but it was faster than moving my plugins into a new build and trying to remember what I changed.  Also I was able to move the changes that were causing the problem into the Finals_Y folder in a custom plugin to prevent future issues...Its not a "quick" fix but its worth a try if your completely jammed up...
« Last Edit: October 01, 2017, 01:22:36 PM by bob.omb »

Re: PECMD: pecmd.exe - unknown hard error
« Reply #2 on: October 01, 2017, 01:37:59 PM »

dazza

  • Apprentice
  • *
  • Date Registered: Jan 2017
  • Posts: 9
no none of my plugins were modified, just standard ones from the project page mainly and some from gena

I will continue testing tomorrow then and just select a few at a time, or start afresh with the zip download - thanks for reply

Re: PECMD: pecmd.exe - unknown hard error
« Reply #3 on: October 02, 2017, 01:24:40 AM »

Lancelot

  • Gena Baker
  • Grand Chef
  • *****
  • Date Registered: Sep 2010
  • Posts: 7239
and some from gena
All Gena plugins that you can use on SE also available at \Downloads\ (vice versa)

See:
http://theoven.org/index.php?topic=1208.0

I strickly advise to take plugins from \Downloads\ other than manual things.

If there is a plugin you use and get from Gena but not available at \Downloads\ , let us know.

:turtle:

Re: PECMD: pecmd.exe - unknown hard error
« Reply #4 on: October 02, 2017, 02:51:24 AM »

dazza

  • Apprentice
  • *
  • Date Registered: Jan 2017
  • Posts: 9
Okay I have found the cause of the error

I started with a clean download and worked through to find out which plugin caused error

And it is the yy_Theme.script plugin in Build folder - in previous releases e.g. Win10PE_SE_2016-12-23 that plugin was obviously optional as I didn't have it or use it and build/boot worked fine, but since recent release it is now a mandatory plugin

Anyway problem solved - thanks

Re: PECMD: pecmd.exe - unknown hard error
« Reply #5 on: October 02, 2017, 11:09:02 AM »

Lancelot

  • Gena Baker
  • Grand Chef
  • *****
  • Date Registered: Sep 2010
  • Posts: 7239
And it is the yy_Theme.script plugin in Build folder - in previous releases e.g. Win10PE_SE_2016-12-23 that plugin was obviously optional as I didn't have it or use it and build/boot worked fine, but since recent release it is now a mandatory plugin

You give wrong information:

Win10PE_SE_2016-12-23
Build\Theme Plugin is obviously mandatory

Win10PE_SE_2015-09-11
Build\Theme Plugin is obviously mandatory


And no related trouble similar to your post.

Cause of the error you have related to something else you do which nobody has yet done.

Reminding:
Changing mandatory plugins, you break the project.
 Then you are responsible for any other failures.

:turtle:


« Last Edit: October 02, 2017, 11:09:24 AM by Lancelot »

Re: PECMD: pecmd.exe - unknown hard error
« Reply #6 on: October 02, 2017, 11:25:38 AM »

dazza

  • Apprentice
  • *
  • Date Registered: Jan 2017
  • Posts: 9
not sure how I gave wrong information Lancelot - I just posted the facts

I have a build folder from Win10PE_SE_2016-12-23 which builds AND boots fine WITHOUT yy_Theme.script plugin as does all previous versions as I use them daily and have done for years - I also rebuilt that version earlier today and it builds AND boots fine without that script

I have another build folder from Win10PE_SE_2017-08-25 which builds and boots fine WITH yy_Theme.script plugin, but if I remove it then I get error message I posted - other than that one plugin change ALL other plugins are identical - hence why I posted my findings

Please do not tell me I posted wrong information when I clearly tested everything first - reason not similar trouble is perhaps because everyone else downloads all plugins and uses then, where I have been using Win10PE_SE from day one and have just updated the plugins I use every time Chris_R releases a new version - so therefore only changed the plugins I had and didn't add any additional ones, hence reason I know previous few builds work fine even if you omit yy_Theme.script plugin, but latest build using Win 10 1703 Creator Update (build 15063) only works with yy_Theme.script plugin present

Can provide the download / screenshots / evidence of Win10PE_SE_2016-12-23 building and booting with yy_Theme.script plugin if needed

And where does it state it is a mandatory plugin?

Anyway point is it works now, and it worked before without it, not a problem, I am just glad it is working and I can continue using it

Thanks for your help as always

Re: PECMD: pecmd.exe - unknown hard error
« Reply #7 on: October 02, 2017, 11:31:33 AM »

dazza

  • Apprentice
  • *
  • Date Registered: Jan 2017
  • Posts: 9
EDIT: perhaps I should have said I didn't know it was a mandatory plugin because in the past it worked without it, but now I know it is a mandatory plugin I have fixed my problem

Can I perhaps ask how I would know it is mandatory if it doesn't actually state that in the plugin in or on the project page please?

Thanks

Re: PECMD: pecmd.exe - unknown hard error
« Reply #8 on: October 02, 2017, 12:02:46 PM »

Lancelot

  • Gena Baker
  • Grand Chef
  • *****
  • Date Registered: Sep 2010
  • Posts: 7239
Hi dazza,

we have copies of old distributions.

You give wrong information:

Win10PE_SE_2016-12-23
Build\Theme Plugin is obviously mandatory

Win10PE_SE_2015-09-11
Build\Theme Plugin is obviously mandatory

So If you get project here, with your e.g. Win10PE_SE_2016-12-23
 It is not possible you did not have Theme Plugin mandatory before

So what you wrote is wrong information :
And it is the yy_Theme.script plugin in Build folder - in previous releases e.g. Win10PE_SE_2016-12-23 that plugin was obviously optional as I didn't have it or use it and build/boot worked fine, but since recent release it is now a mandatory plugin

with other words:
Win10PE_SE_2016-12-23.zip have
Build\Theme Plugin is obviously mandatory

*
check your old zip you got from here.

*
What you might do a year or more ago, change mandatory setting to disable Theme Plugin ?
I do not clearly remember why Theme Plugin is mandatory, I am sure there is a good reason behind.
I only clearly remember Theme plugin moved to \Build\ folder long time ago since Theme plugin was required to be mandatory (maybe for Win81SE or Win8PESE)

Maybe Theme plugin can be optional on Win10PESE maybe not, up to project Admin Chris.

Since removing on your case fix something !!!!

You have to provide full support log so Chris can inspect and decide further.
Main Configuration -> Enable : Create Support Log


**
Shortly, fact is, Theme plugin so far Mandatory including the e.g. Win10PE_SE_2016-12-23
So your statement with saying "was obviously optional" is wrong, you obviously give wrong information.

***
Anyway, provide Support Log so wheels may turn.
« Last Edit: October 02, 2017, 12:03:26 PM by Lancelot »

Re: PECMD: pecmd.exe - unknown hard error
« Reply #9 on: October 02, 2017, 12:39:52 PM »

dazza

  • Apprentice
  • *
  • Date Registered: Jan 2017
  • Posts: 9
Hi Lancelot

Okay thanks

Thing is I didn't download the full zip file - I had a customized build from day one containing just plugins I need/used, and I just update the individual plugins each time new version is released, e.g. just updating plugins I already have, rather than adding anything new, so that is why I never knew it was mandatory as it worked before without it, hence why I said what I did - now I know latest version won't build with out it I include it - so problem solved

Re: PECMD: pecmd.exe - unknown hard error
« Reply #10 on: October 02, 2017, 01:11:48 PM »

Lancelot

  • Gena Baker
  • Grand Chef
  • *****
  • Date Registered: Sep 2010
  • Posts: 7239
And it is the yy_Theme.script plugin in Build folder - in previous releases e.g. Win10PE_SE_2016-12-23 that plugin was obviously optional as I didn't have it or use it and build/boot worked fine, but since recent release it is now a mandatory plugin

so your post was all wrong since you never got Win10PE_SE_2016-12-23......

The way you use project(s) not supported by any project here,
 you create problem yourself, you workaround problem elsewhere, even without providing support log...

following your way of using projects as stated on your previous post:
I had a customized build from day one containing just plugins I need/used, and I just update the individual plugins each time new version is released,

Just tried building latest Win10PESE
This is wrong.


Tried building again multiple times, checked source, searched forum, looked at FAQ's etc, but can't find any mention
FAQ says use default project to test first, so what you wrote is wrong.

+
FAQ also says how to provide support log which you did not.



*****
Next time before asking any support:
use
Utils\Update to update any project.

Your way of using projects not supported.

Following your way, It is no surprise you fail.

I can assure you, with your way you will fail in future (as stated in the past  :wink: )
 and you will do things that are not supported to cover your failure --> problem solved.  :wink:


:turtle:

Re: PECMD: pecmd.exe - unknown hard error
« Reply #11 on: October 02, 2017, 01:31:56 PM »

dazza

  • Apprentice
  • *
  • Date Registered: Jan 2017
  • Posts: 9
okay  :turtle:

Re: PECMD: pecmd.exe - unknown hard error
« Reply #12 on: October 02, 2017, 01:35:57 PM »

dazza

  • Apprentice
  • *
  • Date Registered: Jan 2017
  • Posts: 9
sorry click post before I had finished typing

...

okay thanks for your comments, I understand my way not supported but that is how I have used Win10PE_SE since first release - and other PE versions before that

Completely except my way not supported, but we all do things our own way, doesn't make one of us right and one of us wrong - but I do take your point

Regards

 

Powered by EzPortal