Topic: session ADM with V1709 : i can't return to session system  (Read 234 times)

0 Members and 1 Guest are viewing this topic.

session ADM with V1709 : i can't return to session system
« on: October 30, 2017, 01:27:06 PM »

noelBlanc

  • Chef
  • ***
  • Date Registered: Dec 2013
  • Posts: 121
Hello,
Inside session ADM, I can't return to session system.
"TSCON 1" return error 5023 (decimal).
see "net helpmsg 5023"
Am i the only one with this error ?
Merci

Re: session ADM with V1709 : i can't return to session system
« Reply #1 on: November 07, 2017, 12:58:54 PM »

ChrisR

  • Moderator, Win7PE SE Baker
  • Grand Chef
  • *****
  • Date Registered: Mar 2011
  • Posts: 2911
Salut Noel,
It is already reported here reply #36
I have not found for tscon 1 error 5023, maybe you can help.

Re: session ADM with V1709 : i can't return to session system
« Reply #2 on: November 08, 2017, 12:48:16 PM »

noelBlanc

  • Chef
  • ***
  • Date Registered: Dec 2013
  • Posts: 121
Salut ChrisR,
I missed many thinks in the noticed reply... my bad english...

A funny thing with ADM session : I create a second user, toto, and add it to localgroup administrators.
I always use password for the two users, administrator and toto.
Now, i can switch to toto from administrator and from administrator to toto if a give the password.
Code: [Select]
X:\Users\toto>qwinsta
 SESSIONNAME       USERNAME                 ID  STATE   TYPE        DEVICE
 services                                                           0  Disc
                                                                          1  Disc
                          Administrator                          2  Disc
>console           toto                                          3  Active

X:\Users\toto>tscon 1 /PASSWORD:* /V
Type the password of user owning sessionID 1: >>>>>>>>>>>>>>>>>>< whitch one ?????
Connecting sessionID 1 to sessionname Console
Could not connect sessionID 1 to this session, Error code 5023
Error [5023]:The group or resource is not in the correct state to perform the requested operation.

X:\Users\toto>tscon 2
Could not connect sessionID 2 to this session, Error code 1326
Error [1326]:The user name or password is incorrect. ---------------->>>>>> NEW ???

X:\Users\toto>tscon 2 /PASSWORD:+Noel   ----->>>>> switch is OK
With Windbg, i see that api WinStationConnectW quit rapidely with error 5023.
I'll try an other day to trace but it seems "no chance to get it works a day", security is better or modified in v1709.


 

Powered by EzPortal