Topic: Rufus - Win10PESE x64 - Plugin Development  (Read 325 times)

0 Members and 2 Guests are viewing this topic.

Rufus - Win10PESE x64 - Plugin Development
« on: February 05, 2018, 08:26:57 PM »

bob.omb

  • Chef
  • ***
  • Location: USA
  • Date Registered: Jul 2017
  • Posts: 317
Has anyone ever gotten this working inside PESE?

Can be used to self replicate USB's.  You could reburn the same USB with a different ISO after boot in an emergency(if all apps set to Run From RAM), and switch to something different.. Ninja moves  :tongue:

Without dependencies Rufus appears to run correctly and complete but it errors out during the format phase.

Pete (Author) is not aware of which dependencies may be needed for PE (No PE support)

I tried to trace dependencies for an hour or so with no luck so far.  Anyone interested please feel free to add...


« Last Edit: February 18, 2018, 10:47:27 PM by bob.omb »

Re: Rufus in PESE
« Reply #1 on: February 17, 2018, 09:05:30 AM »

JFX

  • Code Baker
  • Sr. Chef
  • ****
  • Date Registered: Dec 2010
  • Posts: 934
Works fine here  :whistling:
« Last Edit: February 17, 2018, 09:05:58 AM by JFX »

Re: Rufus in PESE
« Reply #2 on: February 17, 2018, 11:25:35 AM »

bob.omb

  • Chef
  • ***
  • Location: USA
  • Date Registered: Jul 2017
  • Posts: 317
I almost removed it from my build.... but now that i know there's hope...  :lol:

Re: Rufus in PESE
« Reply #3 on: February 17, 2018, 11:51:55 AM »

JFX

  • Code Baker
  • Sr. Chef
  • ****
  • Date Registered: Dec 2010
  • Posts: 934
Well it works in PESE x86.
So the easiest solution would be to ask the developer to compile an x64 version for x64 WinPE.
Even if he refuses, it's open source so you could do it yourself.

On the other side you could try to find the dependencies needed by the FormatEx API.

Re: Rufus in PESE
« Reply #4 on: February 17, 2018, 11:56:53 AM »

bob.omb

  • Chef
  • ***
  • Location: USA
  • Date Registered: Jul 2017
  • Posts: 317
I'll post my findings after testing... :turtle:

So far FMIFS.DLL is the only thing I see for FormatEx - Down the rabbit hole  :thumbsup: ty

** ULIB.DLL, IFSUTIL.DLL, IFSUTILX.DLL, UNTFS.DLL, UFAT.DLL, UEXFAT.DLL, UREFS.DLL, and UREFSV1.DLL also..
« Last Edit: February 17, 2018, 12:05:56 PM by bob.omb »

Re: Rufus in PESE
« Reply #5 on: February 17, 2018, 01:24:00 PM »

mynhow

  • Jr. Chef
  • **
  • Date Registered: Oct 2015
  • Posts: 41
Hi.

In my build these files were missing: dsrole.dll - fmifs.dll - fsutilext.dll - UserLanguagesCpl.dll - UserLanguagesCpl.dll.mui

After copying them to Syswow64 rufus worked fine.

Re: Rufus in PESE
« Reply #6 on: February 17, 2018, 10:12:35 PM »

bob.omb

  • Chef
  • ***
  • Location: USA
  • Date Registered: Jul 2017
  • Posts: 317
It gets further with the below dependencies + all muis but it still crashes halfway through testing...This is a mix of FormatEx dependencies and the dependencies mynhow suggested...

Code: [Select]
Set,%PluginArch%,x86
Require_FileQ,dsrole.dll
Require_FileQ,fmifs.dll
Require_FileQ,fsutil.exe
Require_FileQ,fsutilext.dll
Require_FileQ,ifsutil.dll
Require_FileQ,ifsutilx.dll
Require_FileQ,ulib.dll
Require_FileQ,uexfat.dll
Require_FileQ,ufat.dll
Require_FileQ,untfs.dll
Require_FileQ,urefs.dll
Require_FileQ,urefsv1.dll
« Last Edit: February 17, 2018, 10:16:07 PM by bob.omb »

Re: Rufus in PESE
« Reply #7 on: February 17, 2018, 10:45:00 PM »

mynhow

  • Jr. Chef
  • **
  • Date Registered: Oct 2015
  • Posts: 41
Just a question: Are you copying these files to Syswow64?

I ask because of this: Set,%PluginArch%,x86, So, is it not copying the files to system32 instead of Syswow64?


Re: Rufus in PESE
« Reply #8 on: February 18, 2018, 07:42:02 AM »

bob.omb

  • Chef
  • ***
  • Location: USA
  • Date Registered: Jul 2017
  • Posts: 317
Set,%PluginArch%,x86 targets System32 and SysWOW64 in a 64bit build

In 32bit system =====> x86 files in System32

In 64bit system =====> x64 files in System32 -> x86 files in SysWOW64

(In 64bit system) If you Set,%PluginArch%,x86 -> Require_FileQ,xxx.dll copies the DLL and associated MUI 's into System32 AND SysWOW64 to make sure you get the x86 versions too...

I will do more testing on my end standby..
« Last Edit: February 18, 2018, 09:23:07 AM by bob.omb »

Re: Rufus in PESE
« Reply #9 on: February 18, 2018, 10:18:27 AM »

mynhow

  • Jr. Chef
  • **
  • Date Registered: Oct 2015
  • Posts: 41
Hi Bob.

Oh ok, nice. Thank you.  :thumbsup:

I did a basic standard build x64 here to test, then I copied the files I posted and it worked well.

Could you post an image of rufus config and error? So I can try to replicate it.

« Last Edit: February 18, 2018, 10:22:28 AM by mynhow »

Re: Rufus in PESE
« Reply #10 on: February 18, 2018, 10:54:36 AM »

JFX

  • Code Baker
  • Sr. Chef
  • ****
  • Date Registered: Dec 2010
  • Posts: 934
some more:

fveapi.dll
fveapibase.dll
uudf.dll
wimgapi.dll

Re: Rufus in PESE
« Reply #11 on: February 18, 2018, 03:03:17 PM »

bob.omb

  • Chef
  • ***
  • Location: USA
  • Date Registered: Jul 2017
  • Posts: 317
Almost..

I was able to burn a Windows 10 1709 install USB fine without issue.  :thumbsup:

When I tried burning a Win10PESE USB it failed.  :ohmy:  The device suddenly disappears about halfway through as logs show as if it is no longer connected. I tried this normally and then also with the host USB removed and rufus running from ram. Same results..

ila_rendered
ila_rendered

Maybe there is a USB issue on the machine I am using I have to test on something else tomorrow for sure...

Plugin I am using is attached below.
* Rufus_2.18_Plugin_v.1.7z (934.11 kB - downloaded 5 times.)

 
« Last Edit: February 18, 2018, 10:52:34 PM by bob.omb »

 

Powered by EzPortal