Topic: VirtualBox on Win10PESE  (Read 88 times)

0 Members and 1 Guest are viewing this topic.

VirtualBox on Win10PESE
« on: January 10, 2017, 03:47:03 AM »

Gerhard S.

  • Jr. Chef
  • **
  • Date Registered: Dec 2015
  • Posts: 75
Plugin VirtualBox on Win10PESE: (very fast; x64 + x86)

Status: Not complete. Only button 'Launch program' implemented. No Registry-keys.


ila_rendered

ila_rendered
^^Win10PESE_x64.ISO 1.265 GB, no hdd, 3D-acceleration 256MB GFX, 2500MB assigned RAM. Desktop ready after a few seconds.

I'm going to create a plugin. Suggestions & co-workers welcome  :smile:

This script follows licence approval: No changes to company's programm/package files ! To get the whole thing working in Win10PE, we implement their files in PE as they are given!

And many thanks to Oracle for this exquisite program.




How?
->BIOS-settings: Enable VT-x (Intel-CPU) or AMD-V (AMD-CPU). If your CPU has not this capability, VirtualBox runs only 32-Bit Virtual Machines.

1. Look for 'Portable VirtualBox'  (http://www.vbox.me/) --> you get a file named  Portable-VirtualBox_v5.0.26-Starter_v6.4.10-Win_all.exe
 -> Run this or un-zip it:

ila_rendered

2. Run Portable-VirtualBox.exe
 -> Check 'Extract the files for a 64-Bit system'
 -> Download newest Oracle VirtualBox 5.1.12 platform package for Windows Hosts v5.1.12 (VirtualBox-5.1.12-112440-Win.exe) - and point to this file.
 -> Run, install VBoxadditions - and 7-zip this to 'Portable-VirtualBox.7z'. (The resulting archive may not be so huge as showed, only ~65 MB.)

ila_rendered

Sorry, my VirtualBoxPortable.Script is gone. I got a 'Out of system memory'-message. No backup. No chance to recover. (Portable-VirtualBox.7z 98MB was encoded in script; my failure  :sad:)
Enable DirectX.script, DotNet.script 2.0-4.0 full, VcRunTimes.script, Vss.script, Common Components.script
The service VBoxDrv  is needed: (in Win10PE the Portable-VirtualBox doesn't install it)
Code: [Select]
RegHiveLoad,Tmp_System,%RegSystem%
RegWrite,HKLM,0x4,Tmp_System\ControlSet001\Services\VBoxDrv,Type,1
RegWrite,HKLM,0x4,Tmp_System\ControlSet001\Services\VBoxDrv,Start,1
RegWrite,HKLM,0x4,Tmp_System\ControlSet001\Services\VBoxDrv,ErrorControl,1
RegWrite,HKLM,0x2,Tmp_System\ControlSet001\Services\VBoxDrv,ImagePath,\SystemRoot\system32\DRIVERS\VBoxDrv.sys
RegWrite,HKLM,0x1,Tmp_System\ControlSet001\Services\VBoxDrv,DisplayName,"VirtualBox Service"
RegHiveUnLoad,Tmp_System

^^I show this part, because RegPeConvert's output  is maybe not correct. The original Registry-key is: (CurrentControlSet)
Code: [Select]
Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\VBoxDrv]
"Type"=dword:00000001
"Start"=dword:00000001
"ErrorControl"=dword:00000001
"ImagePath"=hex(2):5c,00,53,00,79,00,73,00,74,00,65,00,6d,00,52,00,6f,00,6f,00,\
  74,00,5c,00,73,00,79,00,73,00,74,00,65,00,6d,00,33,00,32,00,5c,00,44,00,52,\
  00,49,00,56,00,45,00,52,00,53,00,5c,00,56,00,42,00,6f,00,78,00,44,00,72,00,\
  76,00,2e,00,73,00,79,00,73,00,00,00
"DisplayName"="VirtualBox Service"



Greetings, Gerhard. Upgraded Laptop to i7-640M (both cores working  :wink: )
« Last Edit: January 13, 2017, 09:04:37 PM by Gerhard S. »

 

Powered by EzPortal