Topic: PENetwork  (Read 16427 times)

0 Members and 1 Guest are viewing this topic.

Re: PENetwork
« Reply #20 on: August 01, 2015, 02:05:32 AM »

KYHI

  • Code Baker
  • Sr. Chef
  • ****
  • Location: Kentucky
  • Date Registered: Jan 2015
  • Posts: 909
Line 326 on script needs to be changed to

Code: [Select]
ShellExecuteEx,Open,%ProjectTemp%\PENetworkWirelessExp\PENetwork.exe,"/wifiexporter #$q%WlanProfilesDir_FileBox%#$q"

Re: PENetwork
« Reply #21 on: December 27, 2015, 08:22:16 AM »

Holger

  • Jr. Chef
  • **
  • Location: Munich
  • Date Registered: Oct 2011
  • Posts: 30
Hello,

just want to inform you that I published a new version 0.59.Beta 3 of PENM:
- Fixed: Connection name not displayed if using WMI
- Fixed: Clicking and displaying of tray info window misbehavior during creating process
- Changed: TrayInfo sorted by connection name (first entry, then device name and network infos)
- Changed: WiFi physical type display to letters instead of letter icons to make it easier to add new types
- Changed: Better dynamic tray info window size
- Changed: Icons in shares GUI to same like in network browsing
- Changed: Device names in tray info window sorted
- Changed: Detection of installed network, tcpip and workstation services are checked if running
- Added: Connection name to TrayInfo
- Added: Tray icon activity is splitted to send/receive actions (all adapters)
- Added: New icons and sizes for different DPI sizes
- Added: Win10 detection
- Added: Show only connected devices in tray info window
- Added: Tray info colors (text, background, transparency) can be changed via ini color scheme/editor
- Added: Firewall tab

At the moment you can download it from:
http://penetwork.bplaced.net
or
http://sourceforge.net/projects/penetwork

I released it now because I still want to change some other things...
The old icons are available in the au3-zip file (ICL format) on the homepage if you don't like the new ones.
The old icons are only support normal display resolution with 96 DPI (100%)!!!

Thanks for using and testing.
Greets and happy new year :)
Holger
« Last Edit: December 27, 2015, 08:23:30 AM by Holger »

Re: PENetwork
« Reply #22 on: December 27, 2015, 09:38:27 AM »

Lancelot

  • Gena Baker
  • Grand Chef
  • *****
  • Date Registered: Sep 2010
  • Posts: 7389
Thanks Holger,

Very nice improvments  :cheerleader: :magic:
so far working very nice  :xmas-good:

updated Gena and Win10PESE Penetwork plugins on server  :xmas-thumbsup:

Happy New Year  :xmas-beer:

ps:
Topic Moved to
    Tool World »    Development and code snippets »  PENetwork
       http://theoven.org/index.php?board=18.0


:turtle:

Re: PENetwork
« Reply #23 on: February 23, 2016, 10:51:16 PM »

KYHI

  • Code Baker
  • Sr. Chef
  • ****
  • Location: Kentucky
  • Date Registered: Jan 2015
  • Posts: 909
Having a slight issue with PENetwork v Latest v0.59.Beta3 on a W10x64 Ram build..
Can not get it to show GUI after startup - always goes to notification area...

Any suggestions ?

Re: PENetwork
« Reply #24 on: September 18, 2016, 02:58:03 AM »

Lancelot

  • Gena Baker
  • Grand Chef
  • *****
  • Date Registered: Sep 2010
  • Posts: 7389
I will be glad if someone tell me which drivers required for VirtualBox network operational on Gena, I feel it changed !?!? since
Gena\Drivers\3 Network\VirtualBox / VMWare Network Driver

does not work for VirtualBox anymore ........

Hi Holger,

I figured out, and fixed "Gena\Drivers\3 Network\VirtualBox / VMWare Network Driver" plugin.

It seems PENetwork (0.59 B3) do not ignore CopyFiles internally on PE (Gena x86 tested),
 Update Inf to replace values required ;)
   I do not know if PENetwork suppose to ignore or not, Only informing.

:turtle:

Re: PENetwork
« Reply #25 on: October 06, 2016, 11:15:01 PM »

Holger

  • Jr. Chef
  • **
  • Location: Munich
  • Date Registered: Oct 2011
  • Posts: 30
Hi folks,

I was very 'busy' the last half year...however, the project is still alive.
So I could not read all whats going on and what problems the tool currently makes.
Just let me know here what other specific problems there are and in which PE version.
- At the moment there are/were problems with changing inf files under Win10PE - this was an old option since VistaPE - it seems that it is not needed anymore (I think starting Win7 or Win8...will test it out).
- Also there seems to be problems with mapping network drives automatically after starting/loading the desktop - also in Win10PE - have to think about a better possibility.
- The driver integrating has also to be changed for newer PE versions - I saw this already at work working with Dism /Add-Driver /Driver /Recurse...

@Lancelot: normally PENM does not change driver inf files in PE1.X environments cause it was not needed before. Here the command "UpdateDriverForPlugAndPlayDevices" with the parameter "INSTALLFLAG_READONLY" is used.
I did a small test here with the contents from the 'meal-zip' and here it works with the VirtualBox drivers without any problems.

Thanks and greets :-)
Holger
« Last Edit: October 06, 2016, 11:15:29 PM by Holger »

Re: PENetwork
« Reply #26 on: October 07, 2016, 02:05:35 AM »

Lancelot

  • Gena Baker
  • Grand Chef
  • *****
  • Date Registered: Sep 2010
  • Posts: 7389
Hi Holger,

Gena Meal default package make things work with
\Drivers\3 Network\'DPs-LAN_Drivers'
\Finals\1 Optimizations\'Post Processing Tools'
so Penetwork on VirtualBox works ok.

with other words,
Gena Meal default package fixes related failures I wrote on previous post.

ps: So far through nearly all development, we use 'Post Processing Tools' -> 'Update Inf' as default. :wink:





Here is test package to reproduce easily and quickly:

https://www.dropbox.com/s/ky20d6enxxt8jtg/Gena_Pack_201610071427.7z?dl=0

Tested with
 - VirtualBox 5.1.4
 - through \VirtualTest\'VirtualBox Emulation' plugin
 - with source XPSP3 x86 Enu

*
Test1:
as default inside package using
\Drivers\3 Network\'VirtualBox / VMWare Network Driver v10 (Gena Meal)'
Fails
-->
It seems new Virtual Box need "E1000325" for Gena-NAT connection (as in 'VirtualBox Emulation' plugin)
Nothing seems to be related to PeNetwork, This is failure of 'VirtualBox / VMWare Network Driver v10 (Gena Meal)' plugin on current Gena Meal zip distribution.
(failure of this plugin covered by 'DPs-LAN_Drivers' + 'Post Processing Tools' ;) )

Test2:
Disable
\Drivers\3 Network\'VirtualBox / VMWare Network Driver v10 (Gena Meal)'
Enable
\Drivers\3 Network\'VirtualBox / VMWare Network Driver Holger TEST'

This adds E1000325.SYS + E1000325.INF to the build
But PeNetwork Fails
It seems PENetwork (0.59 B3) do not ignore CopyFiles (inside E1000325.INF) internally on PE

(This failure covered by 'Post Processing Tools' ;) on Gena)

Test3:
Disable
\Drivers\3 Network\'VirtualBox / VMWare Network Driver v10 (Gena Meal)'
Enable
\Drivers\3 Network\'VirtualBox / VMWare Network Driver Holger TEST'
Enable
Finals\1 Optimizations\'Post Processing Tools'

As you know 'Post Processing Tools' "Update inf" will delete CopyFiles lines from E1000325.INF

PENetwork connected.

*
Test4:
Disable
\Drivers\3 Network\'VirtualBox / VMWare Network Driver v10 (Gena Meal)'
Disable
\Drivers\3 Network\'VirtualBox / VMWare Network Driver Holger TEST'
Enable
\Drivers\3 Network\'VirtualBox / VMWare Network Driver'
Disable
Finals\1 Optimizations\'Post Processing Tools'

PENetwork connected.
'VirtualBox / VMWare Network Driver' plugin works out of box.  :thumbsup:

since latest 'VirtualBox / VMWare Network Driver' plugin work out of box by using E1000325.INF without CopyFiles

*
Tip: you can disable
\Components\Core\1 System\IE06
for faster tests ;)


ps:
+
Test Enable/Disable reference with Gena_Pack_201610071427.7z package
+
'VirtualBox / VMWare Network Driver Holger TEST'
 created specially for you to test updated but unfixed 'VirtualBox / VMWare Network Driver' plugin.




*****
Conclusion
As written before, I feel PENetwork (0.59 B3) do not ignore CopyFiles internally.
 I do not know if PENetwork suppose to ignore or not, Only informing
 
 Maybe this somehow related to PENetwork failures on some other topics around time to time, maybe not. Only informing.
 
 I hope all reproducable and clear now. :turtle:
« Last Edit: October 07, 2016, 02:06:00 AM by Lancelot »

Re: PENetwork
« Reply #27 on: October 08, 2016, 03:59:05 AM »

Holger

  • Jr. Chef
  • **
  • Location: Munich
  • Date Registered: Oct 2011
  • Posts: 30
Hi Lancelot  :smile:

I found the 'problem' with the function "UpdateDriverForPlugAndPlayDevices".
So PENM uses the flag "INSTALLFLAG_READONLY".
That means not just ignoring copying, renaming or deleting driver files but all files used in these inf functions must exist on the target!

This is what PENM however does if you use the driver copying function from the PENM-WB script ("Add drivers from this directory") itself, because it will also copy the needed files like e1000msg.dll, E1000325.din, nicco2.dll and NicInstG.dll.
If these files exist on the target system32 readonly directory then the driver installation will be completed successfully because they exist even they are not really used for something.
I see this at the moment not as problem in PENM but a restriction in the API function.
Years ago for the LiveXP project I always used my internal copying routine so I never had problems with UpdateDriverForPlugAndPlayDevices.

Greets
Holger

Re: PENetwork
« Reply #28 on: October 08, 2016, 11:07:16 AM »

Lancelot

  • Gena Baker
  • Grand Chef
  • *****
  • Date Registered: Sep 2010
  • Posts: 7389
Thanks Holger,

Perfect explanation.  :thumbsup: :thumbsup: :thumbsup:

Cleared every related things.  :great:


On Gena side
 maybe we can add option to use penetwork on some net driver integration
Gena\Drivers\3 Network\DPs LAN Drivers
Gena\Drivers\3 Network\DPs WLAN Drivers
 :wink:

And I learn to check "other files" inside .inf if one day they are required to get a driver work  :smile:



ON SE side I do not know if driver troubles on SE side related to this or not
 (I do not know if dism adds such files like E1000325.din to the build...)
  It is another story.

Thanks   :great:

:turtle:

Re: PENetwork
« Reply #29 on: October 09, 2016, 11:32:52 AM »

Lancelot

  • Gena Baker
  • Grand Chef
  • *****
  • Date Registered: Sep 2010
  • Posts: 7389
Hi Holger,

just an update:

I add "PENetwork Driver Integration" option to
Gena\Drivers\3 Network\'DPs LAN Drivers'
Gena\Drivers\3 Network\'DPs WLAN Drivers'

results quite different especially with 'DPs LAN Drivers' :

On Good side, 'DPs LAN Drivers' with enabled "PENetwork Driver Integration"
As you stated all other files copied  :wink:
And Penetwork nicely connected on VirtualBox 5 without "update inf" :thumbsup:

BUT result lack all DPs injections  :wink: and very very different.

So On Gena I disabled "PENetwork Driver Integration" default.
 In the end we follow DPs way with their packages nicely so far,
   and for LAN/WLAN only update inf required which is also default on Gena.

It is still maybe useful on SE side,
 well they have dism but who knows,
 since there seems no special adjustment for NT6x at DPs,
  so I made plugin to always use "PENetwork Driver Integration" if plugin used on SE.

Available to SE users at
\Downloads\DriversY\'DPs LAN Drivers'
\Downloads\DriversY\'DPs LAN Drivers NT6 File'
\Downloads\DriversY\'DPs WLAN Drivers'
\Downloads\DriversY\'DPs WLAN Drivers NT6 File'
+
Also
\Downloads\Final_Y\'Post Processing Tools'
with only "update inf" option available as default.



Well,
at least we can easily compare results on Gena if one day one like to sum up both DPs and PEnetwork driver injection.
Tip:
Using "Basic Project" Debug interface ease comparision http://theoven.org/index.php?topic=1876.0
 :wink:


Reminding:
Use Utils\Update -> Update button to get all latest plugins from project server.

That is all for now.
:turtle:


Edit:
Also a new plugin at:

Gena\Drivers\6 Other\'Driver Add'
\Downloads\DriversY\'Driver Add'

to add Drivers via Penetwork following .inf   :wink: :thumbsup:
« Last Edit: October 12, 2016, 05:05:40 AM by Lancelot »

Re: PENetwork
« Reply #30 on: November 01, 2016, 04:51:58 AM »

Holger

  • Jr. Chef
  • **
  • Location: Munich
  • Date Registered: Oct 2011
  • Posts: 30
Hello,

just want to inform you that I published a new version 0.59.Beta 4 of PENM:
- Fixed: Program does not close even if set to close after starting network
- Fixed: Program not displayed if started before shell and set to show main window
- Fixed: Replaced old unknown variable type udword by dword
- Changed: Driver inf files patching only if device install failes
- Changed: Driver copying Maj/Min version number

You can download it from:
http://penetwork.bplaced.net
or
http://sourceforge.net/projects/penetwork

Happy testing  :smile:
Holger

Re: PENetwork
« Reply #31 on: November 02, 2016, 12:32:33 AM »

ChrisR

  • Win7PE SE Baker
  • Grand Chef
  • *****
  • Date Registered: Mar 2011
  • Posts: 2911
Hi Holger,

Thanks a lot for the new version 0.59.Beta 4 of PENM  :thumbsup:
In my first test,  all looks fine but I noted that CloseToTray does not seem to work at the first run.
if I relaunch PENetwork, CloseToTray works with the animated Icon in systray.
I tested with win10pese and default value in PENetwork plugin (HKCU: MinimizeToTray=1 ShowTrayActivity=1 StartToTray=1 - HKLM: CloseToTray=1).
« Last Edit: November 02, 2016, 12:32:52 AM by ChrisR »

Re: PENetwork
« Reply #32 on: November 02, 2016, 01:19:01 AM »

Holger

  • Jr. Chef
  • **
  • Location: Munich
  • Date Registered: Oct 2011
  • Posts: 30
Hi Chris,

thanks for feedback  :smile:
However, I do not understand at the moment what the problem is in detail.
Maybe you can post a screenshot of your PENM-options in Winbuilder and describe the steps so I can reproduce it and the things/state that you would expect.

Thanks and greets
Holger

Re: PENetwork
« Reply #33 on: November 02, 2016, 02:00:08 AM »

ChrisR

  • Win7PE SE Baker
  • Grand Chef
  • *****
  • Date Registered: Mar 2011
  • Posts: 2911
ila_rendered
I hope the image is enough to understand and easy to fix.
I would like to have the good animated PENetwork icon in the SysTray at startup,
just after the first run of PENetwork (via RunOnce in PESE).

Here are, if needed, the updated plugin for Win8, 8.1, 10pese, not yet on server:
* penetwork_plugin_v47.7z (3484.25 kB - downloaded 61 times.)

Re: PENetwork
« Reply #34 on: November 02, 2016, 02:49:03 AM »

Holger

  • Jr. Chef
  • **
  • Location: Munich
  • Date Registered: Oct 2011
  • Posts: 30
I did some tests with Win10PESE (build 10240 - x86 and x64 and build 1607 x86) and every time it works.
Can you please copy your %temp%\penmdebug.txt from the running PE and post it here.
At the moment I still have no idea what its going on and whats going wrong. :confused:

Re: PENetwork
« Reply #35 on: November 02, 2016, 03:20:04 AM »

ChrisR

  • Win7PE SE Baker
  • Grand Chef
  • *****
  • Date Registered: Mar 2011
  • Posts: 2911
Tested here with win10 14393 x64. I will do a test with 10240.
I have no CloseToTray in penmdebug.txt:
* PENMDebug.txt (50.88 kB - downloaded 55 times.)

and same log completed after re executing PENetwork, with CloseToTray inside:
* PENMDebug_Include2ndRun.txt (58.71 kB - downloaded 45 times.)

Re: PENetwork
« Reply #36 on: November 02, 2016, 03:44:13 AM »

ChrisR

  • Win7PE SE Baker
  • Grand Chef
  • *****
  • Date Registered: Mar 2011
  • Posts: 2911
I have the same with Win10 10240 x86.
I have the Windows Network Icon but not The animated PENetwork Icon.
* PENMDebug.txt (50.92 kB - downloaded 60 times.)

I must restart PENM a second time to get it.
* PENMDebug_Include2ndRun.txt (58.95 kB - downloaded 54 times.)

I hope you can see whats going wrong with CloseToTray, for me!

« Last Edit: November 02, 2016, 03:47:32 AM by ChrisR »

Re: PENetwork
« Reply #37 on: November 02, 2016, 03:52:02 AM »

Holger

  • Jr. Chef
  • **
  • Location: Munich
  • Date Registered: Oct 2011
  • Posts: 30
Thanks Chris,
I think this is a misunderstanding/misusing problem of some variables which sometimes are confusing (for me too)  :rolleyes:
Maybe in your PENM ini file there is an entry "ShowMain=No" in the [PENetwork] section?
I think I have to change/clean some things to make it more clearer and clearly which option when to use, like MinToTray, StartToTray (sounds similar), CloseToTray, ShowMain...
- MinToTray comes from the old LiveXP project and was something like the original minimizing to tray after initializing network but also is used to minimize the main window into tray if it is shown
- CloseToTray should only switch the main program to tray if the main window is closed or confirmed with [OK] or [Cancel]
- ShowMain should originally popup or not the main windows after initialization network
- StartToTray should originally start the program into tray so without any PENM config window

I have to also update the WinBuilder scripts after that but hopefully it will make more sense then.
Needs some days again.

Re: PENetwork
« Reply #38 on: November 02, 2016, 04:30:32 AM »

ChrisR

  • Win7PE SE Baker
  • Grand Chef
  • *****
  • Date Registered: Mar 2011
  • Posts: 2911
Maybe in your PENM ini file there is an entry "ShowMain=No" in the [PENetwork] section?
YES, That's it, by changed "ShowMain=No" by "ShowMain=Yes" in my PENetwork.ini, it works as I wish. Good detection  :thumbsup:
And indeed, I mixed CloseToTray with StartToTray and I had not seen the link between ShowMain and StartToTray.
With your reminders, it's clear now.
Thanks to you, I'll put the PENetwork plugin on server, with v0.59 beta4 inside for I hope for other feedback, always helpful.

Re: PENetwork
« Reply #39 on: November 06, 2016, 12:18:34 AM »

Lancelot

  • Gena Baker
  • Grand Chef
  • *****
  • Date Registered: Sep 2010
  • Posts: 7389
*
- MinToTray comes from the old LiveXP projec
Hi Holger, LiveXP death, ashes to ashes,
Gena still alive and usable for daily tasks:
 Reply 2 4 November 03, 2016 - http://theoven.org/index.php?topic=1927.msg21673#msg21673
 :wink:
with latest cache developments,
 you can now make basic builds in less than a minute to make quick development tests.  :cool:

*
I will try to follow PENetwork updates on Gena and respond when I have wide free time,
 support on forum and ongoing other developments gets all my small free time.... :turtle:

 

Powered by EzPortal