Topic: PENetwork  (Read 12363 times)

0 Members and 1 Guest are viewing this topic.

PENetwork
« on: January 03, 2012, 11:44:19 AM »

ChrisR

  • Win7PE SE Baker
  • Grand Chef
  • *****
  • Date Registered: Mar 2011
  • Posts: 2809
Good to hear, after a while of waiting, Holger released the new PENetwork v0.57  :thumbsup:
Notice to testers  :wink:

Taken from the post of Holger:
________________________________________
You can find the updated program on my website:
holger.orgfree.com  http://holger.orgfree.com
or
holger.winbuilder.net  http://holger.winbuilder.net


The scripts for WinBuilder will be updated soon.
I know there is still a lot to do and not all problems are solved (ie. problems with Broadcom adapters).

Code: [Select]
29.07.2009  Fixed: WiFi key - now '&', '<', '>' characters will be stored correctly
         Fixed: Internal script bug with some disabled controls - bug not in compiled mode
         Added: Window position will be saved and loaded on GUI start
05.08.2009  Fixed: Missing 'Then' on StartWiFi function
10.09.2009  Removed: Some unused not finished stuff
17.07.2010  Fixed: 64bit - current WiFi connection mark
         Fixed: Missing Adhoc profile in available WiFi network list
         Added: Profile copying in editor
24.07.2010  Fixed: Listview column font misbehaviour
         Fixed: Missing non-broadcast flag on adding WiFi profile
         Fixed: Wrong type saving on adding WiFi adhoc profile
03.08.2010  Changed: WiFi profile changing behaviour
08.11.2010  Fixed: Wrong speed menu items on speed button for some network adapters
         Fixed: Wrong background color on MAC change dialog for current address
01.07.2011  Changed: Tab item behaviour on click
06.07.2011  Fixed: Network card detection/install on 64bit
         Fixed: Run commands after initializing network
         Fixed: 64bit - bug in shares GUI, user query - thanks to John ('Fryquez')
09.10.2011  Changed: Profile editor now saves last used config files
         Added: Profile editor loading file with external editor
12.10.2011  Changed: Start of main GUI
16.10.2011  Fixed: Autoloading of WiFi profiles
         Added: Network browsing in network drives tab
20.10.2011  Fixed: File sharing tab wrong type detection of special shares like IPC$, ADMIN$, etc.
         Fixed: GUI size while switching between full and small tabs
         Changed: DHCP info dialog
         Added: Profile loading file with external editor
22.10.2011  Changed: GUI refreshing to reduce a little bit only flickering
24.10.2011  Changed: Language strings are set to english defaults before loading another language
         Changed: Network browsing - network items are reloaded on collapsing/expanding
09.11.2011  Fixed: Network browsing - latest item is selected if it was selected before
11.11.2011  Fixed: Network browsing - item position change after collapsing
12.12.2011  Added: Profile editor: possiblity to change the GUI frame colors (Main, Properties, WiFi)
02.01.2012  Changed: Small changes for GUI frame colors (Main, Properties, WiFi)
03.02.2012  Changed: Language string now saved in HKCU

:cheers:
« Last Edit: October 11, 2013, 03:20:18 AM by ChrisR »

Re: PENetwork v0.57
« Reply #1 on: January 03, 2012, 10:21:46 PM »

Doberman

  • Jr. Chef
  • **
  • Date Registered: Oct 2011
  • Posts: 74
Thanks ChrisR.  :thumbsup:
Thanks to Holger.  :thumbsup:

For some reason the new penetwork x86 ceased determined : vmxnet.inf ? :confused:

Re: PENetwork v0.57
« Reply #2 on: January 04, 2012, 03:48:40 AM »

JFX

  • Code Baker
  • Sr. Chef
  • ****
  • Date Registered: Dec 2010
  • Posts: 849
hmm, installing of network drivers no longer works with 0.57 
Quote
ER: SetupDiEnumDriverInfoW: 1784


Re: PENetwork v0.57
« Reply #3 on: January 04, 2012, 01:24:20 PM »

ChrisR

  • Win7PE SE Baker
  • Grand Chef
  • *****
  • Date Registered: Mar 2011
  • Posts: 2809
first test for me and same problem with PeNetwork 0,57 x86
installing of network drivers no longer seems to work
No network card detected
Quote
ER: SetupDiEnumDriverInfoW: 259
ER: SetupDiEnumDriverInfoW: 1784

It seems to work better in x64

:cheers:


Re: PENetwork v0.57
« Reply #4 on: January 05, 2012, 01:37:22 PM »

ChrisR

  • Win7PE SE Baker
  • Grand Chef
  • *****
  • Date Registered: Mar 2011
  • Posts: 2809
I continue the messenger :
thanks to you both for device detection bug report  :wink:

_____________________________________
Published version update v.057.1 of PENM:
- Fixed DHCP info dialog (DG, DNS & WINS only 1st address is shown) - thanks to Marco Marro for bug report
- Fixed device detection function - thanks to ChrisR for bug report
- some very small cosmetic changes
- 'Silver' theme as default theme - buildin (classic is still available buildin)

Update is available from
http://holger.orgfree.com
or
http://holger.winbuilder.net

Greets :)
Holger
« Last Edit: January 05, 2012, 01:41:44 PM by ChrisR »

Re: PENetwork v0.57
« Reply #5 on: January 05, 2012, 10:31:07 PM »

Doberman

  • Jr. Chef
  • **
  • Date Registered: Oct 2011
  • Posts: 74
Hi ChrisR :thumbsup:


PeNetwork x64 - no drivers working definition :ohmy:

Re: PENetwork v0.57
« Reply #6 on: January 06, 2012, 10:08:15 PM »

Lancelot

  • Gena Baker
  • Grand Chef
  • *****
  • Date Registered: Sep 2010
  • Posts: 7012
Hi Chris,

an idea is add following to penetwork.script

PNV_ScrollBox="PeNetwork Latest",1,4,314,2,113,21,"PeNetwork 0.5.6","PeNetwork Latest"
but requires lots of changes...........

so I feel it would be much more easier
(easier to adjust, update, edit, maintain.... etc. etc. -> life be less complex  :grin:)
to rename current penetwork.script to penetwork056.script ( and Title=PENetwork 0.5.6=
and
new penetwork.script (current one) with adding latest penetwork ;)

so comparisions and tests would be much more easier by everyone  :cheers:

Re: PENetwork v0.57
« Reply #7 on: January 08, 2012, 12:22:38 PM »

ChrisR

  • Win7PE SE Baker
  • Grand Chef
  • *****
  • Date Registered: Mar 2011
  • Posts: 2809
Hi Lancelot,

so I feel it would be much more easier
(easier to adjust, update, edit, maintain.... etc. etc. -> life be less complex  :grin:)
to rename current penetwork.script to penetwork056.script ( and Title=PENetwork 0.5.6=
and new penetwork.script (current one) with adding latest penetwork ;)

so comparisions and tests would be much more easier by everyone  :cheers:
Good idea :thumbsup:
I updated the current PENetwork script in Win7PE_SE (good for users and testers), pending for new Holger's script with :
- Penetwork v0.57.2 inside and last language files. Politecnico di Torino has updated PENetwork_Ita.lng and I have updated PENetwork_Fr.lng.
- Delete old lang folder,
- Commented out configdot3svc.cmd for wifi seems no longer needed, thanks JFX   :great:
http://w7pese.cwcodes.net/Projects/Win7PE_SE/Components/penetwork.script

The old PENetwork script was kept on the server and renamed in penetwork056.script (disabled by default).

Quote from: Holger
Published version update v.057.2 of PENM:
- Fixed: (again) wrong device detection in 64bit cause of structure size problem in SP_DRVINFO_DATA and SP_DRVINFO_DETAIL_DATA - thanks to 'Fryquez' for bug report

:cheers:

Re: PENetwork v0.57
« Reply #8 on: January 11, 2012, 04:43:47 PM »

Lancelot

  • Gena Baker
  • Grand Chef
  • *****
  • Date Registered: Sep 2010
  • Posts: 7012
I could now update Gena with 0.57.2,
but could not test, besides hoping all ok  :thumbsup:

@JFX

Can you check if bug at adding driver files for x64
( PENetwork.exe /drvcopy )
fixed on Genax64 builds ?
(you can easly test with latest Penetwork plugin on Gena server, all ready for such test  :xmas-cool:)

following history notes, x64 sys files were not copied on previous version (0.56)....

I also feel:
PENetwork.exe /drvcopyx64
PENetwork.exe /drvcopyx86
PENetwork.exe /drvcopyia64
might be better to get PENetwork.exe distinguish right sys files where folder contains both sys files......
What you think ?

 :cheers:
« Last Edit: January 11, 2012, 04:45:13 PM by Lancelot »

Re: PENetwork v0.57
« Reply #9 on: January 12, 2012, 12:17:16 AM »

JFX

  • Code Baker
  • Sr. Chef
  • ****
  • Date Registered: Dec 2010
  • Posts: 849
Quote
UAC detected as enabled - aborting project build
  :w00t: :chair:

Can you check if bug at adding driver files for x64
( PENetwork.exe /drvcopy )
fixed on Genax64 builds ?
(you can easly test with latest Penetwork plugin on Gena server, all ready for such test  :xmas-cool:)
I does work, but you need to add a /x64 to the end of commandline  :xmas-wink:

 :cheers:

Re: PENetwork v0.57
« Reply #10 on: January 12, 2012, 12:44:25 AM »

Lancelot

  • Gena Baker
  • Grand Chef
  • *****
  • Date Registered: Sep 2010
  • Posts: 7012
Thanks a lot
Quote
UAC detected as enabled - aborting project build
  :w00t: :chair:
Basic->PrepPE-->Advanced GUI==>"Abort build if UAC enabled"

You know neither me nor Galapo use nt6x,
we are far away from being experienced on nt6x uac behaviours,
and do not know exact points where UAC is trouble...

What you think,
"Abort build if UAC enabled" default selected false ?
but which conditions requires UAC disabled ?
imdisk installation/usage ?
and/or ?

( ehmmm, quite out of topic, you can reply elsewhere)

I does work, but you need to add a /x64 to the end of commandline  :xmas-wink:

yippi, Thanks,
a mini last touch verify :xmas-wink:,
you mean:
for Source x86

ShellExecute,Hide,%ProjectTemp%\PENetworkDrvCopy\PENetwork.exe,"/drvcopy #$q%pFileBox1%#$q #$q%target_win%#$q%value%"

for Source x64

ShellExecute,Hide,%ProjectTemp%\PENetworkDrvCopy\PENetwork.exe,"/drvcopy #$q%pFileBox1%#$q #$q%target_win%#$q%value% /x64"

 :xmas-beer:

Re: PENetwork v0.57
« Reply #11 on: January 12, 2012, 12:58:20 AM »

JFX

  • Code Baker
  • Sr. Chef
  • ****
  • Date Registered: Dec 2010
  • Posts: 849
for Source x86

ShellExecute,Hide,%ProjectTemp%\PENetworkDrvCopy\PENetwork.exe,"/drvcopy #$q%pFileBox1%#$q #$q%target_win%#$q%value%"

for Source x64

ShellExecute,Hide,%ProjectTemp%\PENetworkDrvCopy\PENetwork.exe,"/drvcopy #$q%pFileBox1%#$q #$q%target_win%#$q%value% /x64"

Yes, correct  :thumbsup:

 :cheers:

Re: PENetwork v0.57
« Reply #12 on: January 12, 2012, 02:00:42 AM »

Lancelot

  • Gena Baker
  • Grand Chef
  • *****
  • Date Registered: Sep 2010
  • Posts: 7012

Re: PENetwork
« Reply #13 on: October 11, 2013, 03:39:52 AM »

ChrisR

  • Win7PE SE Baker
  • Grand Chef
  • *****
  • Date Registered: Mar 2011
  • Posts: 2809
PENetwork 0.58.1 is out  :great:

Holger's home of "PE Network Manager" PENetwork

PENM History : to see all the improvements made in beta and Finals version.
For CommandLine options, Registry options or for 'ini' options (eg: 'PENetwork.ini'), you can look at the FAQs .
Most options are available in PENetwork scripts here or from the PENM editor called from script.

Win7PESE PENetwork
Win8PESE PENetwork

ila_rendered

Thank you very much Holger  :cheerleader:

Re: PENetwork
« Reply #14 on: June 26, 2015, 11:34:08 AM »

Holger

  • Jr. Chef
  • **
  • Location: Munich
  • Date Registered: Oct 2011
  • Posts: 29
Hello,

just want to inform you that I published a new version 0.59.Beta 2 of PENM:
- Fixed: Checkbox text display was truncated
- Fixed: Wrong display for radio boxes in advanced device tab
- Fixed: Wrong decryption for accounts/password with more than 56 characters
- Fixed: Profile applying via cmdline or on first startup if network already is installed
- Fixed: Wrong declined variable
- Fixed: Wrong ini patching routine caused corrupt inf files for PE1.X systems
- Fixed: Wrong tab display with using small tabs
- Changed: "Wpeinit" replaced with "Wpeutil InitializeNetwork" to install and start only needed network services
- Changed: Network adapter is disabled and enabled again instead of restarted after applying changes
- Added: GUI font selection (OS/selfdefined) in PENM/-editor

At the moment you can download it from:
http://penetwork.bplaced.net
or
http://sourceforge.net/projects/penetwork

Re: PENetwork
« Reply #15 on: June 26, 2015, 03:44:33 PM »

0scar

  • Code Baker
  • Chef
  • ***
  • Date Registered: Jan 2013
  • Posts: 179
The translation of the last three lines of PENetwork_Es.lng

Quote
RadioOSFont   ="Usar el tipo de letra del SO para la interfaz (es necesario reiniciar)"
RadioFont   ="Usar este tipo de letra"
ChkIcons   ="Cargar iconos del archivo ini (es necesario reiniciar la interfaz)"

 :smile:

Re: PENetwork
« Reply #16 on: June 30, 2015, 05:58:02 AM »

ChrisR

  • Win7PE SE Baker
  • Grand Chef
  • *****
  • Date Registered: Mar 2011
  • Posts: 2809
Thanks Holger for the new PENetwork version 0.59.Beta 2  :great:

Here is Win8pese, Win8.1se plugin with the choice betwwen PENetwork v0.58.2 or latest version v0.59.B2.
* penetwork.7z (3450.77 kB - downloaded 103 times.)

I successfully tested the Profile applying on first startup on Win8.1SE with the network already started  :thumbsup:

Edit: translation of the last three lines of PENetwork_Fr.lng

Quote
RadioOSFont   ="Utiliser de la police par défaut de l'OS pour l'interface (le redémarrage est requis)"
RadioFont   ="Utiliser la police suivante"
ChkIcons   ="Charger les icones de l'interface à partir du fichier ini (le redémarrage est requis)"
« Last Edit: June 30, 2015, 06:07:22 AM by ChrisR »

Re: PENetwork
« Reply #17 on: July 04, 2015, 05:31:19 AM »

Mikka

  • Code Baker
  • Chef
  • ***
  • Location: Germany
  • Date Registered: May 2012
  • Posts: 234
Great, thanks a bunch for the new script, ChrisR!  :thumbsup:

Oh, by the way... sure that it's
"Charger les icones ..."
and not
"Charger les icônes ..."

Just out of curiosity, I didn't verify myself ...

Re: PENetwork
« Reply #18 on: July 07, 2015, 07:08:33 AM »

ChrisR

  • Win7PE SE Baker
  • Grand Chef
  • *****
  • Date Registered: Mar 2011
  • Posts: 2809
Yes it's better with ô
J’ai toujours été un peu fâché avec les accents circonflexes  :wink:

Re: PENetwork
« Reply #19 on: July 14, 2015, 09:29:01 AM »

Lancelot

  • Gena Baker
  • Grand Chef
  • *****
  • Date Registered: Sep 2010
  • Posts: 7012
Thanks Holger,

I updated plugin on Gena server  :thumbsup:
all things [Process-Infs] [Process-Drivers] done with v0.59 B2  now  :thumbsup:

**

I will be glad if someone tell me which drivers required for VirtualBox network operational on Gena, I feel it changed !?!? since
Gena\Drivers\3 Network\VirtualBox / VMWare Network Driver

does not work for VirtualBox anymore ........

 

Powered by EzPortal