Topic: Require,HighVersion  (Read 1420 times)

0 Members and 2 Guests are viewing this topic.

Require,HighVersion
« on: October 15, 2010, 03:31:07 PM »

Lancelot

  • Moderator, Gena Baker
  • Grand Chef
  • *****
  • Date Registered: Sep 2010
  • Posts: 7012
Only for nt5 (ex: PE1 , Gena) project plugins.

SourceCD independent solution for "where is the highest version of the file" in some cases. (spx.cab driver.cab ... )
With other words:
Instead of using lines with expand.exe, now we have much better: Require,HighVersion

Require,HighVersion,filename,TargetWin|TargetWin\System32|TargetWin\System32\Drivers|ProgramFiles|CommonFiles"

Examples:
Require,HighVersion,msyuv.dll,TargetWin\System32
Require,HighVersion,ndisuio.sys,TargetWin\System32\Drivers

Credits:
Fxscprt's getfile api from his great RF Plugins.




NT6x:
For now only TargetWin\System32 parameter fallback to Require_FileQ to get some compatibility
ex:
Require,HighVersion,msyuv.dll,TargetWin\System32
« Last Edit: December 09, 2015, 05:12:56 AM by Lancelot »

 

Powered by EzPortal