Topic: Win8PESE_Builder does not support WIN8.1 RTM  (Read 15108 times)

0 Members and 1 Guest are viewing this topic.

Win8PESE_Builder does not support WIN8.1 RTM
« on: October 28, 2013, 11:03:40 PM »

hehe520

  • Jr. Chef
  • **
  • Date Registered: Jul 2013
  • Posts: 79
Win8PESE_Builder does not support WIN8.1 RTM
Want to make an WIN8.1 Win8PESE_Builder RTM version



Re: Win8PESE_Builder does not support WIN8.1 RTM
« Reply #1 on: October 29, 2013, 04:54:01 AM »

JonF

  • Code Baker
  • Chef
  • ***
  • Date Registered: Jan 2011
  • Posts: 286
So do we all.

Re: Win8PESE_Builder does not support WIN8.1 RTM
« Reply #2 on: October 30, 2013, 08:02:12 AM »

ChrisR

  • Moderator, Win7PE SE Baker
  • Grand Chef
  • *****
  • Date Registered: Mar 2011
  • Posts: 2809
I started a few small things based on the work of Doberman and Sp_Star :thumbsup:
For now I built it manually with a different approach, the full Install.wim registry hive and a logon as administrator.
It is rather a lightweight Win8.1 OS in Ram, pretty interresting  :cool:

But there is a lot of work to do before proposing something, if I do !
A beta maybe later, if we do it together, I really lack of time.

If someone wants to build something based on Win8PESE or other for Win8.1RTM, it is welcome  :great:

Re: Win8PESE_Builder does not support WIN8.1 RTM
« Reply #3 on: November 11, 2013, 07:30:26 PM »

SIW2

  • Code Baker
  • Chef
  • ***
  • Date Registered: Jul 2012
  • Posts: 168
Chris,

I have it working. 8.1 rtm x64. Using SIB , the taskbar does nothing, but everything else works.

The linkage seems to be vital.

Like this:

[HKEY_LOCAL_MACHINE\WIM_SYSTEM\ControlSet001\Services\{8718928D-CBEB-45EA-A621-800A9249001D}]

These other entries point at that

* LINKAGE.zip (2.37 kB - downloaded 288 times.)

Re: Win8PESE_Builder does not support WIN8.1 RTM
« Reply #4 on: November 12, 2013, 03:35:35 AM »

hehe520

  • Jr. Chef
  • **
  • Date Registered: Jul 2013
  • Posts: 79
制作WIN8.1RTM运行到第二项时弹出这个错误

Re: Win8PESE_Builder does not support WIN8.1 RTM
« Reply #5 on: November 12, 2013, 03:36:06 AM »

hehe520

  • Jr. Chef
  • **
  • Date Registered: Jul 2013
  • Posts: 79
Making WIN8.1 RTM run to the second pop up the error

Re: Win8PESE_Builder does not support WIN8.1 RTM
« Reply #6 on: November 12, 2013, 04:06:34 AM »

SIW2

  • Code Baker
  • Chef
  • ***
  • Date Registered: Jul 2012
  • Posts: 168
Sorry if previous post was not clear. Without the linkage I get dreadful freezes and hangs. Seems to be because network centre is struggling. Putting the linkage entries in fixes it straight away. They are directly from install.wim system hive. I had done that with 8.0 previously also.

ila_rendered

[HKEY_LOCAL_MACHINE\wim-system\ControlSet001\Services\{8718928D-CBEB-45EA-A621-800A9249001D}\Parameters\Tcpip]
"EnableDHCP"=dword:00000001

There are lots of linkages to that , you can find by searching system hive for 8718928D-CBEB-45EA-A621-800A9249001D

For example here:

ila_rendered
« Last Edit: November 12, 2013, 04:11:29 AM by SIW2 »

Re: Win8PESE_Builder does not support WIN8.1 RTM
« Reply #7 on: November 12, 2013, 05:31:36 AM »

hehe520

  • Jr. Chef
  • **
  • Date Registered: Jul 2013
  • Posts: 79
Excuse me, may be I didn't say clear, I'm talking about how to use win8pese production win8.1 PE now run to the second error. You say the key value here is right, I like to do with that didn't, I just changed the win8pese script, now just found win8.1 rim wintool tool file, thank you for your help, hee hee

Re: Win8PESE_Builder does not support WIN8.1 RTM
« Reply #8 on: November 13, 2013, 07:21:29 AM »

ChrisR

  • Moderator, Win7PE SE Baker
  • Grand Chef
  • *****
  • Date Registered: Mar 2011
  • Posts: 2809
Thanks SIW2  :thumbsup:
I advance step by step on WIN8.1 PE with the administrator login and the full Install.wim hive.
And, even without really knowing, I already have the linkage with the full registry.  :wink:

I already have something really not too bad for now but I still have some stuff to do before sharing something   :great:
In the next weeks probably

Re: Win8PESE_Builder does not support WIN8.1 RTM
« Reply #9 on: November 13, 2013, 08:11:17 AM »

Atari800xl

  • Code Baker
  • Sr. Chef
  • ****
  • Date Registered: Feb 2013
  • Posts: 761
Good to hear, ChrisR!! Looking forward to it!!

Re: Win8PESE_Builder does not support WIN8.1 RTM
« Reply #10 on: November 13, 2013, 09:29:56 PM »

SIW2

  • Code Baker
  • Chef
  • ***
  • Date Registered: Jul 2012
  • Posts: 168
Yes, I have also been playing with that using x86. Mine is quite heavy on the ram considering it is x86. Might have a look at putting programs on the usb stick and creating a shortcut to it with pecmd. Recenv appears to behave ok, tho I haven't tried doing a refresh with it yet.

ila_rendered



That is why I have been trying the "normal" way with x64.

Thanks SIW2  :thumbsup:
I advance step by step on WIN8.1 PE with the administrator login and the full Install.wim hive.
And, even without really knowing, I already have the linkage with the full registry.  :wink:

I already have something really not too bad for now but I still have some stuff to do before sharing something   :great:
In the next weeks probably
« Last Edit: November 13, 2013, 09:31:38 PM by SIW2 »

Re: Win8PESE_Builder does not support WIN8.1 RTM
« Reply #11 on: November 15, 2013, 09:44:31 AM »

SIW2

  • Code Baker
  • Chef
  • ***
  • Date Registered: Jul 2012
  • Posts: 168
Logging in as built in admin looks neat at first, but some things will not run - photoviewer for example. Also heavy on the ram which may be an issue for 32 bit users.

Will attempt system recovery options - refresh to see if that works ok from admin pe .

ila_rendered

@ Chris,

Are you able to get refresh to work from your Admin account pe? It isn't working for me. It may be we need to be in System account for that. If so, this Logging in as built in admin is not much use.

Meanwhile,my 64 bit build using SIB is in good shape. No taskbar pinning, but everything else works very well.

« Last Edit: November 15, 2013, 03:15:12 PM by SIW2 »

Re: Win8PESE_Builder does not support WIN8.1 RTM
« Reply #12 on: November 16, 2013, 01:03:17 AM »

ChrisR

  • Moderator, Win7PE SE Baker
  • Grand Chef
  • *****
  • Date Registered: Mar 2011
  • Posts: 2809
Hi SIW2

I see that we have much the same advanced but unfortunately also the same problems  :wink:

I had not really tried photo viewer before, in fact it does not work, no a big worry for it, It can be replaced easily by another third party.
but I saw also for Recovery environment, it does not work with the administrator account and this is a real problem  :confused:
You seem well advanced in your tests  :thumbsup:, have you seen anything else that does not work with admin.
Otherwise, the rest seems really fine and the administrator logon maybe a real bonus for use (ex: teamviewer).
 
What do you mean exactly by the refresh ?
Here, Plug/unplug an usb stick is mounted immediately in explorer.
 
About PE, I had given up the dev because of the locked taskbar. It is a real concern also, maybe I'll redo new tests later in PE.
Is that Recenv works with the system account or downloading from IE?

:cheers:

Re: Win8PESE_Builder does not support WIN8.1 RTM
« Reply #13 on: November 16, 2013, 06:17:47 AM »

Lancelot

  • Gena Baker
  • Grand Chef
  • *****
  • Date Registered: Sep 2010
  • Posts: 7008
but I saw also for Recovery environment, it does not work with the administrator account and this is a real problem  :confused:
an idea, try "Run As System" ;)



Example with psexec.exe :
Code: [Select]
psexec -s -i regedit

--> this one will ease tests




Example without 3rd party (console) :

Code: [Select]
rem sc delete testsvc
sc create testsvc binpath= "cmd /K start" type= own type= interact
sc start testsvc
rem [SC] StartService FAILED 1053: this is expected since CMD.EXE doesn’t have any service related code in it.
exit
http://blogs.msdn.com/b/adioltean/archive/2004/11/27/271063.aspx

--> if this trick works, this can be converted to a nice  RecEvn.cmd  etc. for a "minimized" (or hidden) shortcut...


Just an idea, I hope helps  :thumbsup:
:turtle:

Re: Win8PESE_Builder does not support WIN8.1 RTM
« Reply #14 on: November 16, 2013, 01:40:35 PM »

SIW2

  • Code Baker
  • Chef
  • ***
  • Date Registered: Jul 2012
  • Posts: 168
@Chris,

I mean "refresh your pc", that is one of the rec env options, it is the one most people are likely to use. I can't get it working as Admin.

My other build , logging in as system and using SIB is better so far. The taskbar doesn't work, but that isn't a big problem for me. The start menu and desktop shortcuts do the job fine. Can't d/l with IE as system - that is no problem either, I think most of us prefer another browser in any case.

@Lancelot,

 Thanks will try psexec when I get time.  :grin:
« Last Edit: November 16, 2013, 01:43:11 PM by SIW2 »

Re: Win8PESE_Builder does not support WIN8.1 RTM
« Reply #15 on: November 16, 2013, 05:15:53 PM »

SIW2

  • Code Baker
  • Chef
  • ***
  • Date Registered: Jul 2012
  • Posts: 168
1. Sadly, psexec starts up recenv just fine. Recencv still has exactly the same problem.

Code: [Select]
X:\Users\Administrator.Winpe 8.1\Desktop>psexec.cmd

X:\Users\Administrator.Winpe 8.1\Desktop>tskill explorer

X:\Users\Administrator.Winpe 8.1\Desktop>psexec -i -d -s explorer.exe

PsExec v1.98 - Execute processes remotely
Copyright (C) 2001-2010 Mark Russinovich
Sysinternals - www.sysinternals.com

explorer.exe started on MININT-FS9RG8H with process ID 1420.

X:\Users\Administrator.Winpe 8.1\Desktop>x:\sources\recovery\recenv.exe

psexec -i -s explorer.exe has the same result

2. The testsvc thing doesn't work either.

Code: [Select]
X:\Users\Administrator.Winpe 8.1\Desktop>sc create testsvc binpath= "cmd /K star
t" type= own type= interact
[SC] CreateService SUCCESS

WARNING:  The service testsvc is configured as interactive whose support is bein
g deprecated. The service may not function properly.

X:\Users\Administrator.Winpe 8.1\Desktop>sc start testsvc
[SC] StartService FAILED 1053:

The service did not respond to the start or control request in a timely fashion.

There is no new command window.

According to Adi

Quote
You can use this new service to start as many CMD windows as you want, and you will get a new CMD window as soon as you do a “sc start testsvc” again.

Not anymore:

Code: [Select]
X:\Users\Administrator.Winpe 8.1\Desktop>sc start testsvc
[SC] StartService FAILED 1053:

The service did not respond to the start or control request in a timely fashion.


3. I managed to switch to system account and ran recenv from there. Still the same problem.

Maybe it is not the account which is causing recenv to fail.
« Last Edit: November 16, 2013, 05:21:15 PM by SIW2 »

Re: Win8PESE_Builder does not support WIN8.1 RTM
« Reply #16 on: November 17, 2013, 08:22:19 AM »

SIW2

  • Code Baker
  • Chef
  • ***
  • Date Registered: Jul 2012
  • Posts: 168
psexec -s -i x:\sources\recovery\recenv.exe not working either.

@Chris,

How are you starting it up ?

ila_rendered
« Last Edit: November 17, 2013, 08:23:22 AM by SIW2 »

Re: Win8PESE_Builder does not support WIN8.1 RTM
« Reply #17 on: November 18, 2013, 06:08:43 AM »

ChrisR

  • Moderator, Win7PE SE Baker
  • Grand Chef
  • *****
  • Date Registered: Mar 2011
  • Posts: 2809
Hi SIW2,

Return from Weekend.

How are you starting it up ?
With the administrator logon, I do not use CmdLine with winpeshl or pecmd inside
HKEY_LOCAL_MACHINE\Tmp_System\Setup,CmdLine,""

It uses the standard logon:
HKEY_LOCAL_MACHINE\Tmp_Software\Microsoft\Windows NT\CurrentVersion\Winlogon,Shell,Explorer

With in summary the options after:

- before explorer shell:
Tmp_software\Microsoft\Windows\CurrentVersion\RunOnce,PecmdInit,"Pecmd.exe Load #$pSystemRoot#$p\System32\PecmdInit.ini"
With in PecmdInit:
REGI HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\ProfileList\S-1-5-18\ProfileImagePath=X:\Users\Administrator (required for Shortcuts, Pintool,...)
MountPEmedia (CD, USB mounted on drive Y:)

- After explorer shell 
Tmp_software\Microsoft\Windows\CurrentVersion\Policies\Explorer\Run,PecmdInit,"Pecmd.exe Load #$pSystemRoot#$p\System32\Pecmd.ini"
With in Pecmd:
shortcuts.exe
PinTool.exe (also available with pecmd PINT)
- There is also Autorun.exe > Autorun.cmd or the shortcuts from the startup folder available.

Re: Win8PESE_Builder does not support WIN8.1 RTM
« Reply #18 on: November 18, 2013, 06:44:38 AM »

ChrisR

  • Moderator, Win7PE SE Baker
  • Grand Chef
  • *****
  • Date Registered: Mar 2011
  • Posts: 2809
I repaired photoviewer in my building, It works without concern now   :cool:

And I managed to run System restore  :thumbsup:
By cons, I do not have yet, the "Refresh your PC" option, it starts but does not go to the end of the process.
I corrupted my host system on the first try, fortunately, virtual. I will use the snapshots for the next test  :wink:.
It does not seem to be linked to the user profile, we must be able to make it work without the need for PsExec.
It seems that there are many files dependencies to add. Not really easy to find them, the process is really long.

ila_rendered

ila_rendered
« Last Edit: November 18, 2013, 06:49:03 AM by ChrisR »

Re: Win8PESE_Builder does not support WIN8.1 RTM
« Reply #19 on: November 18, 2013, 08:34:44 AM »

SIW2

  • Code Baker
  • Chef
  • ***
  • Date Registered: Jul 2012
  • Posts: 168
@ Chris,

System restore has always worked on my build. Not too surprising because it works from within installed windows.

The other recenv options are the problem. I added files to boot.wim for my build. I did not remove any. So I don't think there are any files missing. :sad:

I have a hunch it may be a service that we need to get running.

EDIT : I also fixed photoviewer now. :grin:
« Last Edit: November 18, 2013, 12:18:19 PM by SIW2 »

 

Powered by EzPortal