Topic: Win7PE SE things.  (Read 65637 times)

0 Members and 1 Guest are viewing this topic.

Win7PE SE things.
« on: March 23, 2011, 02:22:03 AM »

Lancelot

  • Gena Baker
  • Grand Chef
  • *****
  • Date Registered: Sep 2010
  • Posts: 7261
Hi ChrisR,

I feel it would be more convinient to write things directly related to Win7PE SE here ;) to more organise.

Here are things in my mind to share:
You know, I like to share scripts between projects easly and worked for that since famous VistaPE-Capi.
So far, sharing apps, as well as otheros can be set very common between most projects.
I believe For other sections, Components etc. Better project administration decide what to put in their projects.

Well, some scripts of Gena other than Apps/OtherOS also shareable between projects.

Here are some of them to for you to test at first place:

Gena\Components\Tweaks
Remove Floppy A Mount Point.Script
Remove Floppy ALL Mount Point.Script
they will solve some slow boot issues ;).

recently I default enabled
Gena\Adjunct
MountedDevices Host.script
since I believe most home users use PE on their homepc, and it would be nice surprise to see all letters in nice order ;).

also check
Gena\Components\Core\1 System\
CMD Adds.script
this is a very nice script I've worked a looooot through time, other than anything it very nicely (tidy) summerize cmd tool dependencies you may require for any task :>.

I have not checked but you can test new capi function by using this new calculator script
\Components\Core\1 System\Accessories\Calculator.Script
test with none enu source, I hope you get a french shortcut :>.


well, these are all in my mind for now, I guess a good start :).
I had plans to test all these and than inform you, but everything takes a lot time, contrary I have less time.
I hope you like :)

Re: Win7PE SE things.
« Reply #1 on: March 23, 2011, 05:37:13 AM »

ChrisR

  • Moderator, Win7PE SE Baker
  • Grand Chef
  • *****
  • Date Registered: Mar 2011
  • Posts: 2898
Hi Lancelot

Thank you for this introduction to Win7Pe_Se.
Thank you Galapo for your invitation to Win7Pe_Se.
I know all your wonderful work and the sense of sharing between projects :bravo:

When I have a little time, I will watch the themes to test at first place.


At your is invitation and that of Galapo, I will open, certainly, a new topics to introduce Win7Pe_Se in this section.
This project built on the very good foundation made ​​by JFX (Multi7Pe) and it is improved through many contributions (many of yours  :turtle:). A big thank you to everyone :wub: who participated in this project  :thumbup:.
It must remain as a base with just some few applications.
 
My real job and my family life leaves me less time than before for this project.
So, I hope members here will also help themselves to organize and improve the project.

 :cheers:

Re: Win7PE SE things.
« Reply #2 on: March 23, 2011, 10:10:32 PM »

Lancelot

  • Gena Baker
  • Grand Chef
  • *****
  • Date Registered: Sep 2010
  • Posts: 7261
It must remain as a base with just some few applications.
:thumbsup:
Well, further I believe available options directly about source cd should be available with component-tweak scripts.
As you notice on Gena, there are many component scripts not selected as default  :wink: even some optimizations (direct x , multimedia etc.) not selected default too.
I believe, Increasing number of such scripts do not take much space with giving more confort and control.
Well, requires time..............

Meanwhile, I tested calculator on w7pese, It works  :hi:


Another thing to inform:
I sent following pm to sara - pmedia
Quote
localization mistakes cause black screen, on pe2/3 project solution made historically (since nightman) be providing localization info manually.
to automate (to get localization info and files from source), I believe one better check install.wim hives, personally never found time to work on that.
There is also a practical reason nobody much work on that, it does not serve converting localization of source. ex: using enu source and having hebrew localization on pe not possible with that....
Hence having manual info is more valuable, but requires end user support.

On manual solution, for BASIC type languages, copying all nls and keyboard fixes (at least no black screen ;)), but for COMPLEX type (ex: Hebrew) and EXTENDED type languages more things required which you probably know better.

I remember people from China provided chinese localization things to Make_PE3 in the past......


shortly:
Language support on pe2/3 currently expands with end user support,

and nobody yet provide localization info of Hebrew yet.

on w7pese (and same method through all wb pe2/3 projects) check
\Projects\Win7PE_SE\Build\locale.script

I feel you will be The One who would provide required information for hebrew soon.




Well, I am very loyal to nt5x & pe1, my love/heart hence most free-time truely belongs to Gena  :wub:
well current members here are mostly loyal to pe1 too.......
After a while with available free time, I will find time to export sharable nice components to w7pese,
JonF is one of the first one who set bridges between pe1-2/3 world, maybe he can help in time too.
Everything requires time........
drop by drop  , step by step, :turtle: , things will always get better  :cheers:

Re: Win7PE SE things.
« Reply #3 on: March 25, 2011, 01:04:40 AM »

Galapo

  • Gena Baker
  • Grand Chef
  • *****
  • Location: Australia
  • Date Registered: Sep 2010
  • Posts: 1972
In time I hope to bring build-time shortcut generation to Win7PE_SE for Explorer shell. I had it working in a test build, but the project has been updated since then, as has the ShortcutsCentro script. But the script is entirely opensource, so anyone could do the work if they wanted.

Regards,
Galapo.

Re: Win7PE SE things.
« Reply #4 on: March 31, 2011, 06:38:45 AM »

Lancelot

  • Gena Baker
  • Grand Chef
  • *****
  • Date Registered: Sep 2010
  • Posts: 7261
Hi ChrisR,

I have 2 things:
*
I noticed you changed
%OSServicePack%=
to
%WinServicePack%=

please do not, %OSServicePack% is a very stable variable name we use for a long while now.
SP0
SP1
SP2
....

ex: %OSServicePack%=SP0

*
%OSVersion% or %WinVersion%
I feel useless, I believe JFX put when he first started, but forgot (=not implemented) since never required,
none of projects I know use such thing, because in practice (since more secure), a script author would use
Retrieve,FileVersion,%Source_Sys%\ntdll.dll,%vercheck%
...............
Further up to you.

Re: Win7PE SE things.
« Reply #5 on: March 31, 2011, 11:08:29 AM »

ChrisR

  • Moderator, Win7PE SE Baker
  • Grand Chef
  • *****
  • Date Registered: Mar 2011
  • Posts: 2898
Hi Lancelot,

humm, that's what I did, looking at the variables used in Gena.
In script.project, there is now:
%OSVersion%=             (%WimVversion% before)
%OSServicePack%=       (%WimServicePack% before)

I will create 2 more variables to be supplied from the nice WimInfo.exe  :thumbsup:,
- %SourceVersion%= WimInfo.VERSION
- %SourceServicePack%= SP &  WimInfo.SPLEVEL
as well as existing variables,
- %DistLang% = WimInfo.LANGUAGE
- %SourceArch%= X86 (WimInfo.ARCH=0) ou x64 (WimInfo.ARCH=9). I do not know for ia64 ?
- %WIMIndex%=1 or WimInfo.ImageCount
- %WIMEditionID% = WimInfo.EDITIONID in lowercase now.

and also feed variables in project.ini (SourceType, SysType, Language)


With all these info, I think, perhaps to reorganize a little "Main Configuration" and "0 - PreConfig"
by moving in "Main Configuration" the sections :
HostOSInfoMini
WimInfo
set wimtools and imagex in agreement with SourceServicePack
SaveSettings

and in PreConfig :
HostOSTools
MakeDir   
MountWin7
CheckMountBootWim & CheckMountInstallWim
DetectLang_OldSchool (present method)
SaveSettings

I think it's cleaner, if you have an opinion ?
Regards
 :cheers:




Re: Win7PE SE things.
« Reply #6 on: April 02, 2011, 03:30:59 AM »

Lancelot

  • Gena Baker
  • Grand Chef
  • *****
  • Date Registered: Sep 2010
  • Posts: 7261
Hi  ChrisR,

sorry for late response, it is a busy weekend and I am going with a "priority" & l"ong to work" order :turtle: as much as I can. :thumbsup:

I think there is a misunderstanding,
%OSServicePack% is service pack info of source cd which makes %SourceServicePack% redundant.

As far as I know, hostos servicepack has no importance at all ...

for rest , all looks fine to me now.  :great:
please keep VistaPE-Capi near to check things there ;) it is a good reference to me for years now.  :thumbsup:

I have another reorganisation idea, (fully inspired from nikzzzz image boot organisations on gena)
let me know what you think, Idea is following:
At PostConfig:
Create %basedir%\ISO\WIM\ folder (empty folder)
create bootwim of "%targetdir%\blabla folders" to %basedir%\ISO\WIM\
than copy "rest" of folders+files to %basedir%\ISO\WIM\
create final iso using %basedir%\ISO\WIM\ folder --> %basedir%\ISO\Win7PE_x86.ISO

Advantage:
no problem on editing hives ("mount where" issues)
green button on scripts always operational. (currently runfromcd (=default) scripts will fail regwriting if not mounted, if mounted than they will fail filecopy.....)
being sure wim size did not expand too much due to operations of bootwim (current method), since with this method, after changes, pack+createiso again.

Disadvantage:
yep, some + space on hd (+~500 MB for windows files - I feel not too much for pe2/3 builders).... but I believe advantage is more, still old method can be kept optional or above method can be provided for power users.......

just an idea to share, only keep in mind, nothing urgent at all.

Re: Win7PE SE things.
« Reply #7 on: April 02, 2011, 10:47:13 AM »

ChrisR

  • Moderator, Win7PE SE Baker
  • Grand Chef
  • *****
  • Date Registered: Mar 2011
  • Posts: 2898
Hi Lancelot,

I think there is a misunderstanding,
%OSServicePack% is service pack info of source cd which makes %SourceServicePack% redundant.
OK, it was a misunderstanding (my poor english) :wacko:, yes, only %OSServicePack% as currently
 
please keep VistaPE-Capi near to check things there ;) it is a good reference to me for years now.  :thumbsup:
yes, it's a very good reference

I have another reorganisation idea, (fully inspired from nikzzzz image boot organisations on gena)
............
It is an interesting idea  :thumbsup: for advanced users to :
execute other scripts, editing hives, add files, ...
and no longer need to mount/unmount Target boot.wim.

Option only available for %BuildModel% = "RAM"

For example, I'll call the folder TargetWim.
 
Indeed, the disadvantage is the size and the processing time for,
delete the previous TargetWim and copy again the other folders (Programs, Boot, DriverPacks, others folders at rootCD).

Like that, quickly, I see an option in Main configuration to enable/Disable this function (A name for this function?) :

Disable (Default) %TargetWim% = %TargetDir%
Enable %TargetWim% = %BaseDir%\TargetWim\Win7PE_SE  -  or maybe %basedir%\ISO\WIM\

Then, we must change "Create ISo", "Copy To USB", "Copy To USB BCD",... to use %TargetWim% instead of %TargetDir%

in PostConfig
Quote
Remove %TargetWim%
MakeDir,%TargetWim%
...
DirMake,%BootTMP%
DirMove,"%targetdir%\blablabla,%BootTMP%
...
Packing boot.wim in %TargetWim%\Sources
If "function" enable,
Copy All others Folders from %TargetDir% to %TargetWim%
DirMove,%BootTMP%\blablabla,%targetdir%
Remove %BootTMP%
End
...

A good idea to mature, I have to think more about it ...

See you
 :cheers:
« Last Edit: April 02, 2011, 10:51:03 AM by ChrisR »

Re: Win7PE SE things.
« Reply #8 on: April 03, 2011, 01:34:51 AM »

Lancelot

  • Gena Baker
  • Grand Chef
  • *****
  • Date Registered: Sep 2010
  • Posts: 7261
Hi ChrisR,

I was thinking above as a feature of postconfig script, which would effect createiso script.
This way no pre-requirement on pre-final script organisations  :thumbsup:
no need for a new %BuildModel% value. method do not change, still RAM, same folder organisations during all build, only at final things slightly changes.
but as you wrote, it would effect post-final scripts. :thumbsup:

still, I agree a variable for location maybe required for post-final scripts,
my current suggestions:
%TargetImage%=%basedir%\ISO\WIM\
or maybe
%TargetFinal%=%basedir%\ISO\WIM\
or maybe
%TargetImage%=%basedir%\ISO\RAM\
or maybe
%TargetFinal%=%basedir%\ISO\RAM\
or
......



A good idea to mature, I have to think more about it ...
yep,
There are other things having higher priority,
Tests & Integration of Homes32's Reborn WimUtil ,
hence having w7sp1 source support,
with some new source methods (mount with wimmount or wimfiltr OR use extracted source)
and maybe later, better source language support (sad, no feedback for hebrew yet ;))

only keep above idea :idea: in mind  , one day  :turtle: , nothing critical at all.  :great:

ex: Gena PE1 idea came up at the end of last summer, it took 7 months to accomplish  :wink: nature of hoby projects, slow development speed with ideas in mind, getting better everyday with team spirit (Saydin77, Galapo, Nikzzzz, bluelife, olegpov, JFX, JonF, amalux, Rui Paz oriensol, little Lancelot, acus, amalux...... ) . At least this is my philosophy. That is the reason I sometimes call myself Turtle :turtle: with being slower than everybody around with keeping looots of ideas in mind.



See you.  :cheers:
« Last Edit: April 03, 2011, 02:00:08 AM by Lancelot »

Re: Win7PE SE things.
« Reply #9 on: April 04, 2011, 02:43:48 AM »

ChrisR

  • Moderator, Win7PE SE Baker
  • Grand Chef
  • *****
  • Date Registered: Mar 2011
  • Posts: 2898
Hi,

There are other things having higher priority,
Tests & Integration of Homes32's Reborn WimUtil ,
hence having w7sp1 source support,
with some new source methods (mount with wimmount or wimfiltr OR use extracted source)
and maybe later, better source language support (sad, no feedback for hebrew yet ;))
Yes, quite agree, but it can be easily feasible with the variable %TargetFinal%=%basedir%\ISO\WIM\
With some changes in PostCong and a little work in post-final scripts (%TargetFinal% replacing ,%TargetDir%, and others little things)

For %BuildModel%="RAM", it was just to say that this option is useless, in this case.
For hebrew, I wrote also to Sara, she replied that she looked at, no news since !

I do not forget, either, to test the scripts CMD Adds.script, Calculator.Script, ... and the very usefull ShortcutsCentro script of Galapo  :great: , but later.

_________________
 There are currently imagex.exe(6.0), wimgapi.dll(6.0), wimfltr.inf, wimfltr.sys in the folders %Tools%\x86 and %Tools%\x64

     I look at a good idea to manage both versions 6.0 and 6.1 of imagex. exe and wimgapi.dll.
     A solution could be to have the 2 versions (in same folder) renamed in:
     imagex6.0.exe, wimgapi6.0.dll and
     imagex6.1.exe, wimgapi6.1.dll
     In the two folders x64/x86

     And during Building of the project,
     If the source is Win7 SP0, copy imagex6.0.exe, wimgapi6.0.dll   in   imagex.exe, wimgapi.dll
     Or if the source is Win7 SP1 (not compatible with wimfltr), copy imagex6.1.exe, wimgapi6.1.dll   in   imagex.exe, wimgapi.dll.
     An idea  :idea:
_________________


Other things, for those in x86 Hostos, no problem to recover wimgapi.dll, winmount.inf, winmount.sys and wimserv.exe in the image install.wim of sources win7 x86 or x64
For x64 Hostos and a x64 source win7 no problem also,
by cons for x64 Hostos and a x86 source win7 not possible to recover the x64 versions of wimmount.sys, ... domage.

That is the reason I sometimes call myself Turtle :turtle: with being slower than everybody around with keeping looots of ideas in mind.
Do you know The Tortoise and the Hare http://en.wikipedia.org/wiki/The_Tortoise_and_the_Hare of the French poet Jean de La Fontaine
I would like to be as slow as you  :wink:

Edit: Thank you very much, for the update scripts,the actualization in Win7Pe Se :thumbsup:
   
:cheers:
« Last Edit: April 04, 2011, 03:39:33 AM by ChrisR »

Re: Win7PE SE things.
« Reply #10 on: April 05, 2011, 10:06:47 AM »

Lancelot

  • Gena Baker
  • Grand Chef
  • *****
  • Date Registered: Sep 2010
  • Posts: 7261
Hi ChrisR,

I like your imagex file naming idea at tools,

also, keep in mind the possibility of source be in extracted folders, hence no need for imagex at allllll  :lol:
(go homes32 goooo  :cheerleader:)

it is normal not having wimmount.sys and related things with source-host mismatch architecture,
above idea is still at hand since wimgapi.dll is still there at syswow64 of source, and 7z always at hand, further homes32 wimutil to capture.... :).

also imagex can be selected through installed waik pointing folder (check vistape-capi preconfig) which is sometimes more "sensible" for new users...

.......too many things in my mind to comment, but I am sure you already know.............

well there are too many options and things to work around, waiting to be organised on pre-config nicely......
I closely know not easy task, good luck my turtle friend :) ,
In the end, I am sure you come with a very nice organisation.  :great:


yep, I know Tortoise and the Hare, from walt disney cartoons :)
here is a verry old one ;) look how different bugs bunny is
http://disneydvd.disney.go.com/disney-animation-collection-volume-4-the-tortoise-and-the-hare.html
but even on latest cartoons, turtle is very same ;).
We are all Ninja PE Turtles, :turtle:  :grin:

Re: Win7PE SE things.
« Reply #11 on: April 08, 2011, 04:13:03 AM »

ChrisR

  • Moderator, Win7PE SE Baker
  • Grand Chef
  • *****
  • Date Registered: Mar 2011
  • Posts: 2898
A precision on 7-Zip with files wim:

- for version 4.xx, the index image are marked 1, 2, ...  with the file information 1.xml  (single or multiple images).
      7z.exe e  "...install.wim" -i!"2\windows\system32\wimgapi.dll" -o"OutDir" -y

- for version 9.xx with multiple images, the index image are noted [1], [2], ... with the file information [1]. xml.
      7z.exe e  "...install.wim" -i!"[2]\windows\system32\wimgapi.dll" -o"OutDir" -y

- for version 9.xx with a single image, no more index image and file information.
      7z.exe e  "...install.wim" -i!"windows\system32\wimgapi.dll" -o"OutDir" -y

this complicates a bit.
 :cheers:

Re: Win7PE SE things.
« Reply #12 on: April 08, 2011, 08:07:18 AM »

Lancelot

  • Gena Baker
  • Grand Chef
  • *****
  • Date Registered: Sep 2010
  • Posts: 7261
Hi ChrisR,

as far as I see, you want to put 7z v4x support to wim extraction task on preconfig,
solution already provided by Homes32 with "ExtractWim" macro to be used on preconfig script  :thumbsup:

just fill

[ExtractWim_All_4]

[ExtractWim_One_4]

at the attached "demonstration" script to fullfill your goal.

This way, on next preconfig script, if such organisational change made by 7z author (I feel it will not happen, but who knows) with a new 7z version, it will be easy to add support.

http://www.mediafire.com/?5rvv79oxuliufwv

 :thumbsup::turtle:

Re: Win7PE SE things.
« Reply #13 on: April 08, 2011, 11:10:47 AM »

ChrisR

  • Moderator, Win7PE SE Baker
  • Grand Chef
  • *****
  • Date Registered: Mar 2011
  • Posts: 2898
Thank you for the example macro  :smile:
I do not know if I'll use all the macro as there is version 9.20 in Win7PE SE and no reason to go back, but that does not cost more.

:cheers:





« Last Edit: April 08, 2011, 11:11:50 AM by ChrisR »

Re: Win7PE SE things.
« Reply #14 on: April 15, 2011, 01:57:42 AM »

ChrisR

  • Moderator, Win7PE SE Baker
  • Grand Chef
  • *****
  • Date Registered: Mar 2011
  • Posts: 2898
Hi,
I finished developments (at last awaiting for amendment and validation) of Win7PE SE for use also with Win7 SP1 as source CD, using WimInfo, InstallWimSYS, WimUtil  :rolleyes:.

I did a lot of change in Main Configuration and PreConfig :
   - Compatible with Win7 SP0/SP1
   - supports for WimUtil
   - Wim information
   - Retrieve wim tools in automatic (Waik, HostOS, Install.wim)
   - Language
   - Interface Source Information
   .....
 
I wait for your feedback if you have time to look at the new package  (Lancelot, Homes32, ...) .
Ps: I'm leaving tomorrow for a week holiday. :surfing:

Here are the changes http://www.mediafire.com/?yynckmyb1y4tacp

 :cheers:

Re: Win7PE SE things.
« Reply #15 on: April 15, 2011, 01:28:22 PM »

ChrisR

  • Moderator, Win7PE SE Baker
  • Grand Chef
  • *****
  • Date Registered: Mar 2011
  • Posts: 2898
Package updated in accordance with WimUtil v3.1.1   :cool:  Thank you Homes32  :thumbsup:

Package_2011_04_16 http://www.mediafire.com/?hqf90ry7nddfm1f

Ps: In main configuration, if you choose, wim tools "auto", ImageX is priorities for now waiting for more feedback on Wimutil, but you can choose wimutil as tool.

 :cheers:

Re: Win7PE SE things.
« Reply #16 on: April 15, 2011, 01:29:46 PM »

Lancelot

  • Gena Baker
  • Grand Chef
  • *****
  • Date Registered: Sep 2010
  • Posts: 7261
Hi ChrisR,

I see a lot work indeed  :thumbsup:

I uninstalled all wimfltr-wimmount files services etc from my hostos,
used w7sp0 source,
and failed with prerequest html ;).


Can we have an option to select bootwim and installwim folders on preconfig ?
this way One can use the extracted files (folders) on harddisk :), without any issue of mount  .
(and with homes32 reborn wimutil......:dance: )
If required, to keep backward compatibility, we may even use imagenone.exe at tools which simply does nothing  :rolleyes:

what you think ?

Re: Win7PE SE things.
« Reply #17 on: April 15, 2011, 02:13:19 PM »

ChrisR

  • Moderator, Win7PE SE Baker
  • Grand Chef
  • *****
  • Date Registered: Mar 2011
  • Posts: 2898
Hi Lancelot,

I uninstalled all wimfltr-wimmount files services etc from my hostos,
used w7sp0 source,
and failed with prerequest html ;).
There should have a Bug ! thanks for your "first" feedback  :smile:
preconfig is supposed to do :
  - Retrieve wim tools (wimgapi.dll, wimmount.sys, wimserv.exe) from Waik (wimfltr if Vista waik), @systemDir, extract from install.wim with 7z.
  - checking wim tools (wimgapi, imagex or wimutil)
  - Install WimFilter if needed (wimfltr or wimmount)
  - .......
and Prerequest is for checking this. I will tried to reproduce the Bug, after my Vacation .


Can we have an option to select bootwim and installwim folders on preconfig ?
this way One can use the extracted files (folders) on harddisk :), without any issue of mount  .
(and with homes32 reborn wimutil......:dance: )
If required, to keep backward compatibility, we may even use imagenone.exe at tools which simply does nothing  :rolleyes:

what you think ?
Yes, I have personally some trouble with win7 SP1 and wimmount  :pulpfiction: , I much prefer, the SP0 with wimfltr. Your idea would solve these issues.
but I must rework all scripts mount, unmount, Capi (OnBuildExit : Unmount Wim). And therefore timeee.

Edit, I don't know imagenone but yes in this case the work is facilitated.

See you.
 :cheers:
« Last Edit: April 15, 2011, 02:18:37 PM by ChrisR »

Re: Win7PE SE things.
« Reply #18 on: April 15, 2011, 02:28:05 PM »

Lancelot

  • Gena Baker
  • Grand Chef
  • *****
  • Date Registered: Sep 2010
  • Posts: 7261
Hi ChrisR,

sorry for misunderstanding, On previous post Prerequest check is okey to me  :thumbsup: since I use host x64 source x86  :thumbsup: :thumbsup:
but now, I use source w7x64 (sp0) and I get "wimgapi.dll was not found !!! " message ....,
but in fact, preconfig extracted wimgapi6.1.dll wimmount.sys wimfltr.inf wimmount.inf wimserv.exe
inside tools\x64\  successfully.
Now when I start build again I get
"Wim file information missing. A problem occured to Get Image Information with WimUtil"
at an earlier step....

I need to update with Reply #15 package, and gather tools files to test further when i find time.

but I must rework all scripts mount, unmount, Capi (OnBuildExit : Unmount Wim)
I guess imagexnone.exe may help to solve these,
(imagexnone.exe is an empty au3 that does nothing ;))
but still requires time and work (sorry, I am very busy with Gena these days to jump in that.......)

what I believe, after such work, future is bright to new nt6x - pe2/3/4... organisations, this way end user responsible to provide folder in a way he/she decides...

yesss time......

Re: Win7PE SE things.
« Reply #19 on: April 15, 2011, 02:47:38 PM »

ChrisR

  • Moderator, Win7PE SE Baker
  • Grand Chef
  • *****
  • Date Registered: Mar 2011
  • Posts: 2898
sorry for misunderstanding, On previous post Prerequest check is okey to me  :thumbsup: since I use host x64 source x86  :thumbsup: :thumbsup:
Ok, good  :smile:



but now, I use source w7x64 (sp0) and I get "wimgapi.dll was not found !!! " message ....,
but in fact, preconfig extracted wimgapi6.1.dll wimmount.sys wimfltr.inf wimmount.inf wimserv.exe
inside tools\x64\  successfully.
Now when I start build again I get
"Wim file information missing. A problem occured to Get Image Information with WimUtil"
at an earlier step....
For "wimgapi.dll was not found !!! " this must be a Bug !
for the second message, I have this issue sometime with wimutil, and at second test it is good.



yesss time......
yes and also time to go to bed now :wink:.

 

Powered by EzPortal